mpg123: correct powerpc cpu variant selection
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 2 Jun 2014 11:29:11 +0000 (13:29 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 2 Jun 2014 11:29:11 +0000 (13:29 +0200)
Fixes http://autobuild.buildroot.net/results/d8a/d8af8f991b4429cf06081ddf2f08043861842a50/

ppc_nofpu should (as the name indicates) only be used for powerpc.

It is not clear to me if this code works for powerpc64(le) as well, so this
is only selected for classic ppc32.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mpg123/mpg123.mk

index ac641326a9b32f47046f5c981f80bc9eac2c8860..712738ea214bfbfc061638e0e0eac4e8e3f9afd7 100644 (file)
@@ -30,12 +30,14 @@ ifeq ($(BR2_i386),y)
 MPG123_CPU = x86
 endif
 
+ifeq ($(BR2_powerpc),y)
 ifeq ($(BR2_POWERPC_CPU_HAS_ALTIVEC),y)
 MPG123_CPU = altivec
 endif
 ifeq ($(BR2_SOFT_FLOAT),y)
 MPG123_CPU = ppc_nofpu
 endif
+endif # powerpc
 
 ifeq ($(BR2_x86_64),y)
 MPG123_CPU = x86-64