package/go: drop GO_TARGET_ENV / GO_HOST_ENV
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 29 Aug 2020 09:15:49 +0000 (11:15 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 29 Aug 2020 12:35:49 +0000 (14:35 +0200)
Now that GO_TARGET_ENV and GO_HOST_ENV are just aliases to
HOST_GO_TARGET_ENV and HOST_GO_HOST_ENV, drop the former two, and use
the latter two directly.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/pkg-golang.mk

index 9904ddcc1ab6d9f52b2580d446a1e70ae05bc152..7424c31924ef74829aec82098f9a90bcf02fa8e2 100644 (file)
 
 GO_BIN = $(HOST_DIR)/bin/go
 
-GO_TARGET_ENV = \
-       $(HOST_GO_TARGET_ENV)
-
-GO_HOST_ENV = \
-       $(HOST_GO_HOST_ENV)
-
 ################################################################################
 # inner-golang-package -- defines how the configuration, compilation and
 # installation of a Go package should be done, implements a few hooks to tune
@@ -102,7 +96,7 @@ endif
 define $(2)_BUILD_CMDS
        $$(foreach d,$$($(2)_BUILD_TARGETS),\
                cd $$($(2)_SRC_PATH); \
-               $$(GO_TARGET_ENV) \
+               $$(HOST_GO_TARGET_ENV) \
                        GOPATH="$$(@D)/$$($(2)_WORKSPACE)" \
                        $$($(2)_GO_ENV) \
                        $$(GO_BIN) build -v $$($(2)_BUILD_OPTS) \
@@ -115,7 +109,7 @@ else
 define $(2)_BUILD_CMDS
        $$(foreach d,$$($(2)_BUILD_TARGETS),\
                cd $$($(2)_SRC_PATH); \
-               $$(GO_HOST_ENV) \
+               $$(HOST_GO_HOST_ENV) \
                        GOPATH="$$(@D)/$$($(2)_WORKSPACE)" \
                        $$($(2)_GO_ENV) \
                        $$(GO_BIN) build -v $$($(2)_BUILD_OPTS) \