ibrdtn-tools: fix linking problem when building statically
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Thu, 10 Sep 2015 10:03:00 +0000 (11:03 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 4 Oct 2015 09:43:21 +0000 (11:43 +0200)
The problem looks like this:

/br/output/host/usr/mipsel-buildroot-linux-uclibc/sysroot/usr//lib/librt.a(timer_routines.os):
In function `__start_helper_thread':
timer_routines.c:(.text+0x2f4): undefined reference to `pthread_atfork'
collect2: error: ld returned 1 exit status

Adding -pthread to LDFLAGS fixes the problem.

Fixes:

  http://autobuild.buildroot.net/results/a87/a87a764d3a28f835ed8645923594f7023a662ae8/

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ibrdtn-tools/ibrdtn-tools.mk

index 34f05a6228680095397bb5bb2dd086fc7a9b629b..97ec3c9e171cc77ec5cf0b72b74fed047695abb6 100644 (file)
@@ -10,6 +10,10 @@ IBRDTN_TOOLS_LICENSE = Apache-2.0
 IBRDTN_TOOLS_LICENSE_FILES = COPYING
 IBRDTN_TOOLS_DEPENDENCIES = ibrcommon ibrdtn host-pkgconf
 
+ifeq ($(BR2_STATIC_LIBS),y)
+IBRDTN_TOOLS_CONF_ENV += LDFLAGS="$(TARGET_LDFLAGS) -pthread"
+endif
+
 ifeq ($(BR2_PACKAGE_LIBDAEMON),y)
 IBRDTN_TOOLS_CONF_OPTS += --with-libdaemon
 IBRDTN_TOOLS_DEPENDENCIES += libdaemon