gettext: don't patch different the host and target build
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 27 May 2013 13:01:00 +0000 (13:01 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 30 May 2013 19:45:03 +0000 (21:45 +0200)
Until now, the gettext source code was being patched differently for
the host and the target build, which is going to be incompatible with
out-of-tree build. The difference is that the gettext tools could be
disabled in the target build, but are always enabled on the host
build.

Therefore, this commit switches the gettext package to using proper
patches against the relevant configure.ac and Makefile.am
files. gettext is now being autoreconfigured. Configuration options
are also passed for the host variant, in order to disable the build of
a large number of things we don't care about.

Finally, the two existing patches are renamed to include a number in
their filename.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/gettext/gettext-01-error_print_progname.patch [new file with mode: 0644]
package/gettext/gettext-02-fix_rpl_gettimeofday.patch [new file with mode: 0644]
package/gettext/gettext-03-option-to-disable-tools.patch [new file with mode: 0644]
package/gettext/gettext-04-remove-examples-tests.patch [new file with mode: 0644]
package/gettext/gettext-05-use-shell.patch [new file with mode: 0644]
package/gettext/gettext-error_print_progname.patch [deleted file]
package/gettext/gettext-fix_rpl_gettimeofday.patch [deleted file]
package/gettext/gettext.mk

diff --git a/package/gettext/gettext-01-error_print_progname.patch b/package/gettext/gettext-01-error_print_progname.patch
new file mode 100644 (file)
index 0000000..189d28b
--- /dev/null
@@ -0,0 +1,14 @@
+--- gettext-0.16.1.oorig/gettext-tools/gnulib-lib/error.h      2006-11-27 18:14:50.000000000 +0100
++++ gettext-0.16.1/gettext-tools/gnulib-lib/error.h    2007-06-20 13:29:32.000000000 +0200
+@@ -50,7 +50,10 @@ extern void error_at_line (int __status,
+ /* If NULL, error will flush stdout, then print on stderr the program
+    name, a colon and a space.  Otherwise, error will call this
+    function without parameters instead.  */
+-extern DLL_VARIABLE void (*error_print_progname) (void);
++#ifndef __UCLIBC__
++extern DLL_VARIABLE
++#endif
++void (*error_print_progname) (void);
+ /* This variable is incremented each time `error' is called.  */
+ extern DLL_VARIABLE unsigned int error_message_count;
diff --git a/package/gettext/gettext-02-fix_rpl_gettimeofday.patch b/package/gettext/gettext-02-fix_rpl_gettimeofday.patch
new file mode 100644 (file)
index 0000000..e97ceb2
--- /dev/null
@@ -0,0 +1,282 @@
+Newer sys_time.in.h from gnulib breaks on uClibc with C++ so roll back
+to a previous version that's known to work.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff -Nura gettext-0.18.2.1.orig/gettext-tools/gnulib-lib/sys_time.in.h gettext-0.18.2.1/gettext-tools/gnulib-lib/sys_time.in.h
+--- gettext-0.18.2.1.orig/gettext-tools/gnulib-lib/sys_time.in.h       2013-03-12 09:17:10.530475932 -0300
++++ gettext-0.18.2.1/gettext-tools/gnulib-lib/sys_time.in.h    2013-03-19 12:00:17.557958255 -0300
+@@ -1,6 +1,6 @@
+ /* Provide a more complete sys/time.h.
+-   Copyright (C) 2007-2013 Free Software Foundation, Inc.
++   Copyright (C) 2007-2012 Free Software Foundation, Inc.
+    This program is free software; you can redistribute it and/or modify
+    it under the terms of the GNU General Public License as published by
+@@ -17,34 +17,37 @@
+ /* Written by Paul Eggert.  */
+-#ifndef _@GUARD_PREFIX@_SYS_TIME_H
+-
+ #if __GNUC__ >= 3
+ @PRAGMA_SYSTEM_HEADER@
+ #endif
+ @PRAGMA_COLUMNS@
+-/* The include_next requires a split double-inclusion guard.  */
+-#if @HAVE_SYS_TIME_H@
+-# @INCLUDE_NEXT@ @NEXT_SYS_TIME_H@
+-#endif
++#if defined _@GUARD_PREFIX@_SYS_TIME_H
+-#ifndef _@GUARD_PREFIX@_SYS_TIME_H
+-#define _@GUARD_PREFIX@_SYS_TIME_H
++/* Simply delegate to the system's header, without adding anything.  */
++# if @HAVE_SYS_TIME_H@
++#  @INCLUDE_NEXT@ @NEXT_SYS_TIME_H@
++# endif
+-#if ! @HAVE_SYS_TIME_H@
+-# include <time.h>
+-#endif
++#else
++
++# define _@GUARD_PREFIX@_SYS_TIME_H
++
++# if @HAVE_SYS_TIME_H@
++#  @INCLUDE_NEXT@ @NEXT_SYS_TIME_H@
++# else
++#  include <time.h>
++# endif
+ /* On native Windows with MSVC, get the 'struct timeval' type.
+    Also, on native Windows with a 64-bit time_t, where we are overriding the
+    'struct timeval' type, get all declarations of system functions whose
+    signature contains 'struct timeval'.  */
+-#if (defined _MSC_VER || @REPLACE_STRUCT_TIMEVAL@) && @HAVE_WINSOCK2_H@ && !defined _GL_INCLUDING_WINSOCK2_H
+-# define _GL_INCLUDING_WINSOCK2_H
+-# include <winsock2.h>
+-# undef _GL_INCLUDING_WINSOCK2_H
+-#endif
++# if (defined _MSC_VER || @REPLACE_STRUCT_TIMEVAL@) && @HAVE_WINSOCK2_H@ && !defined _GL_INCLUDING_WINSOCK2_H
++#  define _GL_INCLUDING_WINSOCK2_H
++#  include <winsock2.h>
++#  undef _GL_INCLUDING_WINSOCK2_H
++# endif
+ /* The definitions of _GL_FUNCDECL_RPL etc. are copied here.  */
+@@ -52,112 +55,112 @@
+ /* The definition of _GL_WARN_ON_USE is copied here.  */
+-#ifdef __cplusplus
++# ifdef __cplusplus
+ extern "C" {
+-#endif
++# endif
+-#if !@HAVE_STRUCT_TIMEVAL@ || @REPLACE_STRUCT_TIMEVAL@
++# if !@HAVE_STRUCT_TIMEVAL@ || @REPLACE_STRUCT_TIMEVAL@
+-# if @REPLACE_STRUCT_TIMEVAL@
+-#  define timeval rpl_timeval
+-# endif
++#  if @REPLACE_STRUCT_TIMEVAL@
++#   define timeval rpl_timeval
++#  endif
+-# if !GNULIB_defined_struct_timeval
++#  if !GNULIB_defined_struct_timeval
+ struct timeval
+ {
+   time_t tv_sec;
+   long int tv_usec;
+ };
+-#  define GNULIB_defined_struct_timeval 1
+-# endif
++#   define GNULIB_defined_struct_timeval 1
++#  endif
+-#endif
++# endif
+-#ifdef __cplusplus
++# ifdef __cplusplus
+ }
+-#endif
++# endif
+-#if @GNULIB_GETTIMEOFDAY@
+-# if @REPLACE_GETTIMEOFDAY@
+-#  if !(defined __cplusplus && defined GNULIB_NAMESPACE)
+-#   undef gettimeofday
+-#   define gettimeofday rpl_gettimeofday
+-#  endif
++# if @GNULIB_GETTIMEOFDAY@
++#  if @REPLACE_GETTIMEOFDAY@
++#   if !(defined __cplusplus && defined GNULIB_NAMESPACE)
++#    undef gettimeofday
++#    define gettimeofday rpl_gettimeofday
++#   endif
+ _GL_FUNCDECL_RPL (gettimeofday, int,
+-                  (struct timeval *restrict, void *restrict)
++                  (struct timeval *__restrict, void *__restrict)
+                   _GL_ARG_NONNULL ((1)));
+ _GL_CXXALIAS_RPL (gettimeofday, int,
+-                  (struct timeval *restrict, void *restrict));
+-# else
+-#  if !@HAVE_GETTIMEOFDAY@
++                  (struct timeval *__restrict, void *__restrict));
++#  else
++#   if !@HAVE_GETTIMEOFDAY@
+ _GL_FUNCDECL_SYS (gettimeofday, int,
+-                  (struct timeval *restrict, void *restrict)
++                  (struct timeval *__restrict, void *__restrict)
+                   _GL_ARG_NONNULL ((1)));
+-#  endif
++#   endif
+ /* Need to cast, because on glibc systems, by default, the second argument is
+                                                   struct timezone *.  */
+ _GL_CXXALIAS_SYS_CAST (gettimeofday, int,
+-                       (struct timeval *restrict, void *restrict));
+-# endif
++                       (struct timeval *__restrict, void *__restrict));
++#  endif
+ _GL_CXXALIASWARN (gettimeofday);
+-#elif defined GNULIB_POSIXCHECK
+-# undef gettimeofday
+-# if HAVE_RAW_DECL_GETTIMEOFDAY
++# elif defined GNULIB_POSIXCHECK
++#  undef gettimeofday
++#  if HAVE_RAW_DECL_GETTIMEOFDAY
+ _GL_WARN_ON_USE (gettimeofday, "gettimeofday is unportable - "
+                  "use gnulib module gettimeofday for portability");
++#  endif
+ # endif
+-#endif
+ /* Hide some function declarations from <winsock2.h>.  */
+-#if defined _MSC_VER && @HAVE_WINSOCK2_H@
+-# if !defined _@GUARD_PREFIX@_UNISTD_H
+-#  if !(defined __cplusplus && defined GNULIB_NAMESPACE)
+-#   undef close
+-#   define close close_used_without_including_unistd_h
+-#  else
++# if defined _MSC_VER && @HAVE_WINSOCK2_H@
++#  if !defined _@GUARD_PREFIX@_UNISTD_H
++#   if !(defined __cplusplus && defined GNULIB_NAMESPACE)
++#    undef close
++#    define close close_used_without_including_unistd_h
++#   else
+      _GL_WARN_ON_USE (close,
+                       "close() used without including <unistd.h>");
+-#  endif
+-#  if !(defined __cplusplus && defined GNULIB_NAMESPACE)
+-#   undef gethostname
+-#   define gethostname gethostname_used_without_including_unistd_h
+-#  else
++#   endif
++#   if !(defined __cplusplus && defined GNULIB_NAMESPACE)
++#    undef gethostname
++#    define gethostname gethostname_used_without_including_unistd_h
++#   else
+      _GL_WARN_ON_USE (gethostname,
+                       "gethostname() used without including <unistd.h>");
++#   endif
+ #  endif
+-# endif
+-# if !defined _@GUARD_PREFIX@_SYS_SOCKET_H
+-#  if !(defined __cplusplus && defined GNULIB_NAMESPACE)
+-#   undef socket
+-#   define socket              socket_used_without_including_sys_socket_h
+-#   undef connect
+-#   define connect             connect_used_without_including_sys_socket_h
+-#   undef accept
+-#   define accept              accept_used_without_including_sys_socket_h
+-#   undef bind
+-#   define bind                bind_used_without_including_sys_socket_h
+-#   undef getpeername
+-#   define getpeername         getpeername_used_without_including_sys_socket_h
+-#   undef getsockname
+-#   define getsockname         getsockname_used_without_including_sys_socket_h
+-#   undef getsockopt
+-#   define getsockopt          getsockopt_used_without_including_sys_socket_h
+-#   undef listen
+-#   define listen              listen_used_without_including_sys_socket_h
+-#   undef recv
+-#   define recv                recv_used_without_including_sys_socket_h
+-#   undef send
+-#   define send                send_used_without_including_sys_socket_h
+-#   undef recvfrom
+-#   define recvfrom            recvfrom_used_without_including_sys_socket_h
+-#   undef sendto
+-#   define sendto              sendto_used_without_including_sys_socket_h
+-#   undef setsockopt
+-#   define setsockopt          setsockopt_used_without_including_sys_socket_h
+-#   undef shutdown
+-#   define shutdown            shutdown_used_without_including_sys_socket_h
+-#  else
++#  if !defined _@GUARD_PREFIX@_SYS_SOCKET_H
++#   if !(defined __cplusplus && defined GNULIB_NAMESPACE)
++#    undef socket
++#    define socket              socket_used_without_including_sys_socket_h
++#    undef connect
++#    define connect             connect_used_without_including_sys_socket_h
++#    undef accept
++#    define accept              accept_used_without_including_sys_socket_h
++#    undef bind
++#    define bind                bind_used_without_including_sys_socket_h
++#    undef getpeername
++#    define getpeername         getpeername_used_without_including_sys_socket_h
++#    undef getsockname
++#    define getsockname         getsockname_used_without_including_sys_socket_h
++#    undef getsockopt
++#    define getsockopt          getsockopt_used_without_including_sys_socket_h
++#    undef listen
++#    define listen              listen_used_without_including_sys_socket_h
++#    undef recv
++#    define recv                recv_used_without_including_sys_socket_h
++#    undef send
++#    define send                send_used_without_including_sys_socket_h
++#    undef recvfrom
++#    define recvfrom            recvfrom_used_without_including_sys_socket_h
++#    undef sendto
++#    define sendto              sendto_used_without_including_sys_socket_h
++#    undef setsockopt
++#    define setsockopt          setsockopt_used_without_including_sys_socket_h
++#    undef shutdown
++#    define shutdown            shutdown_used_without_including_sys_socket_h
++#   else
+      _GL_WARN_ON_USE (socket,
+                       "socket() used without including <sys/socket.h>");
+      _GL_WARN_ON_USE (connect,
+@@ -186,18 +189,17 @@
+                       "setsockopt() used without including <sys/socket.h>");
+      _GL_WARN_ON_USE (shutdown,
+                       "shutdown() used without including <sys/socket.h>");
++#   endif
+ #  endif
+-# endif
+-# if !defined _@GUARD_PREFIX@_SYS_SELECT_H
+-#  if !(defined __cplusplus && defined GNULIB_NAMESPACE)
+-#   undef select
+-#   define select select_used_without_including_sys_select_h
+-#  else
++#  if !defined _@GUARD_PREFIX@_SYS_SELECT_H
++#   if !(defined __cplusplus && defined GNULIB_NAMESPACE)
++#    undef select
++#    define select select_used_without_including_sys_select_h
++#   else
+      _GL_WARN_ON_USE (select,
+                       "select() used without including <sys/select.h>");
++#   endif
+ #  endif
+ # endif
+-#endif
+ #endif /* _@GUARD_PREFIX@_SYS_TIME_H */
+-#endif /* _@GUARD_PREFIX@_SYS_TIME_H */
diff --git a/package/gettext/gettext-03-option-to-disable-tools.patch b/package/gettext/gettext-03-option-to-disable-tools.patch
new file mode 100644 (file)
index 0000000..24a9996
--- /dev/null
@@ -0,0 +1,42 @@
+Add a --disable-tools option
+
+This patch adds a --disable-tools option that allows to disable the
+compilation of the gettext tools, which may not be necessary on a
+small embedded Linux system.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/configure.ac
+===================================================================
+--- a/configure.ac
++++ b/configure.ac
+@@ -37,6 +37,10 @@
+ dnl Checks for library functions.
++AC_ARG_ENABLE([tools], [--disable-tools  do not build tools],
++                     [enable_tools=$enableval], [enable_tools=yes])
++AM_CONDITIONAL([ENABLE_TOOLS], [test "$enable_tools" = "yes"])
++
+ AC_CONFIG_SUBDIRS([gettext-runtime gettext-tools])
+ dnl Ensure that "configure --help" lists all the command line options that
+Index: b/Makefile.am
+===================================================================
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -20,7 +20,13 @@
+ ACLOCAL = build-aux/fixaclocal @ACLOCAL@
+ ACLOCAL_AMFLAGS = -I m4
+-SUBDIRS = gnulib-local gettext-runtime gettext-tools
++if ENABLE_TOOLS
++TOOLS_SUBDIR = gettext-tools
++else
++TOOLS_SUBDIR =
++endif
++
++SUBDIRS = gnulib-local gettext-runtime $(TOOLS_SUBDIR)
+ EXTRA_DIST = \
+   version.sh DEPENDENCIES PACKAGING HACKING ChangeLog.0 autogen.sh \
diff --git a/package/gettext/gettext-04-remove-examples-tests.patch b/package/gettext/gettext-04-remove-examples-tests.patch
new file mode 100644 (file)
index 0000000..f7d88d9
--- /dev/null
@@ -0,0 +1,20 @@
+Disable tests and examples
+
+This patch disables the gettext-tools tests and examples, which are
+generally not necessary.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/gettext-tools/Makefile.am
+===================================================================
+--- a/gettext-tools/Makefile.am
++++ b/gettext-tools/Makefile.am
+@@ -20,7 +20,7 @@
+ ACLOCAL = ../build-aux/fixaclocal @ACLOCAL@
+ ACLOCAL_AMFLAGS = -I m4 -I ../gettext-runtime/m4 -I ../m4 -I gnulib-m4 -I libgrep/gnulib-m4 -I libgettextpo/gnulib-m4
+-SUBDIRS = doc intl gnulib-lib libgrep src libgettextpo po projects styles misc man m4 tests gnulib-tests examples
++SUBDIRS = doc intl gnulib-lib libgrep src libgettextpo po projects styles misc man m4
+ EXTRA_DIST = misc/DISCLAIM
+ MOSTLYCLEANFILES = core *.stackdump
diff --git a/package/gettext/gettext-05-use-shell.patch b/package/gettext/gettext-05-use-shell.patch
new file mode 100644 (file)
index 0000000..5f6e2c2
--- /dev/null
@@ -0,0 +1,25 @@
+gettext-runtime: use @SHELL@ for the SHELL variable definition
+
+The gettext-runtime/Makefile.in uses an hardcoded SHELL = /bin/sh
+variable. This causes problems at build time, because libtool is then
+called with the 'sh' shell, which does not support the += construct
+that the libtool script is using.
+
+Instead, this Makefile.in should be definining SHELL = @SHELL@, just
+like all other Makefile.in of gettext.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/gettext-runtime/intl/Makefile.in
+===================================================================
+--- a/gettext-runtime/intl/Makefile.in
++++ b/gettext-runtime/intl/Makefile.in
+@@ -17,7 +17,7 @@
+ PACKAGE = @PACKAGE@
+ VERSION = @VERSION@
+-SHELL = /bin/sh
++SHELL = @SHELL@
+ srcdir = @srcdir@
+ top_srcdir = @top_srcdir@
diff --git a/package/gettext/gettext-error_print_progname.patch b/package/gettext/gettext-error_print_progname.patch
deleted file mode 100644 (file)
index 189d28b..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
---- gettext-0.16.1.oorig/gettext-tools/gnulib-lib/error.h      2006-11-27 18:14:50.000000000 +0100
-+++ gettext-0.16.1/gettext-tools/gnulib-lib/error.h    2007-06-20 13:29:32.000000000 +0200
-@@ -50,7 +50,10 @@ extern void error_at_line (int __status,
- /* If NULL, error will flush stdout, then print on stderr the program
-    name, a colon and a space.  Otherwise, error will call this
-    function without parameters instead.  */
--extern DLL_VARIABLE void (*error_print_progname) (void);
-+#ifndef __UCLIBC__
-+extern DLL_VARIABLE
-+#endif
-+void (*error_print_progname) (void);
- /* This variable is incremented each time `error' is called.  */
- extern DLL_VARIABLE unsigned int error_message_count;
diff --git a/package/gettext/gettext-fix_rpl_gettimeofday.patch b/package/gettext/gettext-fix_rpl_gettimeofday.patch
deleted file mode 100644 (file)
index e97ceb2..0000000
+++ /dev/null
@@ -1,282 +0,0 @@
-Newer sys_time.in.h from gnulib breaks on uClibc with C++ so roll back
-to a previous version that's known to work.
-
-Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
-
-diff -Nura gettext-0.18.2.1.orig/gettext-tools/gnulib-lib/sys_time.in.h gettext-0.18.2.1/gettext-tools/gnulib-lib/sys_time.in.h
---- gettext-0.18.2.1.orig/gettext-tools/gnulib-lib/sys_time.in.h       2013-03-12 09:17:10.530475932 -0300
-+++ gettext-0.18.2.1/gettext-tools/gnulib-lib/sys_time.in.h    2013-03-19 12:00:17.557958255 -0300
-@@ -1,6 +1,6 @@
- /* Provide a more complete sys/time.h.
--   Copyright (C) 2007-2013 Free Software Foundation, Inc.
-+   Copyright (C) 2007-2012 Free Software Foundation, Inc.
-    This program is free software; you can redistribute it and/or modify
-    it under the terms of the GNU General Public License as published by
-@@ -17,34 +17,37 @@
- /* Written by Paul Eggert.  */
--#ifndef _@GUARD_PREFIX@_SYS_TIME_H
--
- #if __GNUC__ >= 3
- @PRAGMA_SYSTEM_HEADER@
- #endif
- @PRAGMA_COLUMNS@
--/* The include_next requires a split double-inclusion guard.  */
--#if @HAVE_SYS_TIME_H@
--# @INCLUDE_NEXT@ @NEXT_SYS_TIME_H@
--#endif
-+#if defined _@GUARD_PREFIX@_SYS_TIME_H
--#ifndef _@GUARD_PREFIX@_SYS_TIME_H
--#define _@GUARD_PREFIX@_SYS_TIME_H
-+/* Simply delegate to the system's header, without adding anything.  */
-+# if @HAVE_SYS_TIME_H@
-+#  @INCLUDE_NEXT@ @NEXT_SYS_TIME_H@
-+# endif
--#if ! @HAVE_SYS_TIME_H@
--# include <time.h>
--#endif
-+#else
-+
-+# define _@GUARD_PREFIX@_SYS_TIME_H
-+
-+# if @HAVE_SYS_TIME_H@
-+#  @INCLUDE_NEXT@ @NEXT_SYS_TIME_H@
-+# else
-+#  include <time.h>
-+# endif
- /* On native Windows with MSVC, get the 'struct timeval' type.
-    Also, on native Windows with a 64-bit time_t, where we are overriding the
-    'struct timeval' type, get all declarations of system functions whose
-    signature contains 'struct timeval'.  */
--#if (defined _MSC_VER || @REPLACE_STRUCT_TIMEVAL@) && @HAVE_WINSOCK2_H@ && !defined _GL_INCLUDING_WINSOCK2_H
--# define _GL_INCLUDING_WINSOCK2_H
--# include <winsock2.h>
--# undef _GL_INCLUDING_WINSOCK2_H
--#endif
-+# if (defined _MSC_VER || @REPLACE_STRUCT_TIMEVAL@) && @HAVE_WINSOCK2_H@ && !defined _GL_INCLUDING_WINSOCK2_H
-+#  define _GL_INCLUDING_WINSOCK2_H
-+#  include <winsock2.h>
-+#  undef _GL_INCLUDING_WINSOCK2_H
-+# endif
- /* The definitions of _GL_FUNCDECL_RPL etc. are copied here.  */
-@@ -52,112 +55,112 @@
- /* The definition of _GL_WARN_ON_USE is copied here.  */
--#ifdef __cplusplus
-+# ifdef __cplusplus
- extern "C" {
--#endif
-+# endif
--#if !@HAVE_STRUCT_TIMEVAL@ || @REPLACE_STRUCT_TIMEVAL@
-+# if !@HAVE_STRUCT_TIMEVAL@ || @REPLACE_STRUCT_TIMEVAL@
--# if @REPLACE_STRUCT_TIMEVAL@
--#  define timeval rpl_timeval
--# endif
-+#  if @REPLACE_STRUCT_TIMEVAL@
-+#   define timeval rpl_timeval
-+#  endif
--# if !GNULIB_defined_struct_timeval
-+#  if !GNULIB_defined_struct_timeval
- struct timeval
- {
-   time_t tv_sec;
-   long int tv_usec;
- };
--#  define GNULIB_defined_struct_timeval 1
--# endif
-+#   define GNULIB_defined_struct_timeval 1
-+#  endif
--#endif
-+# endif
--#ifdef __cplusplus
-+# ifdef __cplusplus
- }
--#endif
-+# endif
--#if @GNULIB_GETTIMEOFDAY@
--# if @REPLACE_GETTIMEOFDAY@
--#  if !(defined __cplusplus && defined GNULIB_NAMESPACE)
--#   undef gettimeofday
--#   define gettimeofday rpl_gettimeofday
--#  endif
-+# if @GNULIB_GETTIMEOFDAY@
-+#  if @REPLACE_GETTIMEOFDAY@
-+#   if !(defined __cplusplus && defined GNULIB_NAMESPACE)
-+#    undef gettimeofday
-+#    define gettimeofday rpl_gettimeofday
-+#   endif
- _GL_FUNCDECL_RPL (gettimeofday, int,
--                  (struct timeval *restrict, void *restrict)
-+                  (struct timeval *__restrict, void *__restrict)
-                   _GL_ARG_NONNULL ((1)));
- _GL_CXXALIAS_RPL (gettimeofday, int,
--                  (struct timeval *restrict, void *restrict));
--# else
--#  if !@HAVE_GETTIMEOFDAY@
-+                  (struct timeval *__restrict, void *__restrict));
-+#  else
-+#   if !@HAVE_GETTIMEOFDAY@
- _GL_FUNCDECL_SYS (gettimeofday, int,
--                  (struct timeval *restrict, void *restrict)
-+                  (struct timeval *__restrict, void *__restrict)
-                   _GL_ARG_NONNULL ((1)));
--#  endif
-+#   endif
- /* Need to cast, because on glibc systems, by default, the second argument is
-                                                   struct timezone *.  */
- _GL_CXXALIAS_SYS_CAST (gettimeofday, int,
--                       (struct timeval *restrict, void *restrict));
--# endif
-+                       (struct timeval *__restrict, void *__restrict));
-+#  endif
- _GL_CXXALIASWARN (gettimeofday);
--#elif defined GNULIB_POSIXCHECK
--# undef gettimeofday
--# if HAVE_RAW_DECL_GETTIMEOFDAY
-+# elif defined GNULIB_POSIXCHECK
-+#  undef gettimeofday
-+#  if HAVE_RAW_DECL_GETTIMEOFDAY
- _GL_WARN_ON_USE (gettimeofday, "gettimeofday is unportable - "
-                  "use gnulib module gettimeofday for portability");
-+#  endif
- # endif
--#endif
- /* Hide some function declarations from <winsock2.h>.  */
--#if defined _MSC_VER && @HAVE_WINSOCK2_H@
--# if !defined _@GUARD_PREFIX@_UNISTD_H
--#  if !(defined __cplusplus && defined GNULIB_NAMESPACE)
--#   undef close
--#   define close close_used_without_including_unistd_h
--#  else
-+# if defined _MSC_VER && @HAVE_WINSOCK2_H@
-+#  if !defined _@GUARD_PREFIX@_UNISTD_H
-+#   if !(defined __cplusplus && defined GNULIB_NAMESPACE)
-+#    undef close
-+#    define close close_used_without_including_unistd_h
-+#   else
-      _GL_WARN_ON_USE (close,
-                       "close() used without including <unistd.h>");
--#  endif
--#  if !(defined __cplusplus && defined GNULIB_NAMESPACE)
--#   undef gethostname
--#   define gethostname gethostname_used_without_including_unistd_h
--#  else
-+#   endif
-+#   if !(defined __cplusplus && defined GNULIB_NAMESPACE)
-+#    undef gethostname
-+#    define gethostname gethostname_used_without_including_unistd_h
-+#   else
-      _GL_WARN_ON_USE (gethostname,
-                       "gethostname() used without including <unistd.h>");
-+#   endif
- #  endif
--# endif
--# if !defined _@GUARD_PREFIX@_SYS_SOCKET_H
--#  if !(defined __cplusplus && defined GNULIB_NAMESPACE)
--#   undef socket
--#   define socket              socket_used_without_including_sys_socket_h
--#   undef connect
--#   define connect             connect_used_without_including_sys_socket_h
--#   undef accept
--#   define accept              accept_used_without_including_sys_socket_h
--#   undef bind
--#   define bind                bind_used_without_including_sys_socket_h
--#   undef getpeername
--#   define getpeername         getpeername_used_without_including_sys_socket_h
--#   undef getsockname
--#   define getsockname         getsockname_used_without_including_sys_socket_h
--#   undef getsockopt
--#   define getsockopt          getsockopt_used_without_including_sys_socket_h
--#   undef listen
--#   define listen              listen_used_without_including_sys_socket_h
--#   undef recv
--#   define recv                recv_used_without_including_sys_socket_h
--#   undef send
--#   define send                send_used_without_including_sys_socket_h
--#   undef recvfrom
--#   define recvfrom            recvfrom_used_without_including_sys_socket_h
--#   undef sendto
--#   define sendto              sendto_used_without_including_sys_socket_h
--#   undef setsockopt
--#   define setsockopt          setsockopt_used_without_including_sys_socket_h
--#   undef shutdown
--#   define shutdown            shutdown_used_without_including_sys_socket_h
--#  else
-+#  if !defined _@GUARD_PREFIX@_SYS_SOCKET_H
-+#   if !(defined __cplusplus && defined GNULIB_NAMESPACE)
-+#    undef socket
-+#    define socket              socket_used_without_including_sys_socket_h
-+#    undef connect
-+#    define connect             connect_used_without_including_sys_socket_h
-+#    undef accept
-+#    define accept              accept_used_without_including_sys_socket_h
-+#    undef bind
-+#    define bind                bind_used_without_including_sys_socket_h
-+#    undef getpeername
-+#    define getpeername         getpeername_used_without_including_sys_socket_h
-+#    undef getsockname
-+#    define getsockname         getsockname_used_without_including_sys_socket_h
-+#    undef getsockopt
-+#    define getsockopt          getsockopt_used_without_including_sys_socket_h
-+#    undef listen
-+#    define listen              listen_used_without_including_sys_socket_h
-+#    undef recv
-+#    define recv                recv_used_without_including_sys_socket_h
-+#    undef send
-+#    define send                send_used_without_including_sys_socket_h
-+#    undef recvfrom
-+#    define recvfrom            recvfrom_used_without_including_sys_socket_h
-+#    undef sendto
-+#    define sendto              sendto_used_without_including_sys_socket_h
-+#    undef setsockopt
-+#    define setsockopt          setsockopt_used_without_including_sys_socket_h
-+#    undef shutdown
-+#    define shutdown            shutdown_used_without_including_sys_socket_h
-+#   else
-      _GL_WARN_ON_USE (socket,
-                       "socket() used without including <sys/socket.h>");
-      _GL_WARN_ON_USE (connect,
-@@ -186,18 +189,17 @@
-                       "setsockopt() used without including <sys/socket.h>");
-      _GL_WARN_ON_USE (shutdown,
-                       "shutdown() used without including <sys/socket.h>");
-+#   endif
- #  endif
--# endif
--# if !defined _@GUARD_PREFIX@_SYS_SELECT_H
--#  if !(defined __cplusplus && defined GNULIB_NAMESPACE)
--#   undef select
--#   define select select_used_without_including_sys_select_h
--#  else
-+#  if !defined _@GUARD_PREFIX@_SYS_SELECT_H
-+#   if !(defined __cplusplus && defined GNULIB_NAMESPACE)
-+#    undef select
-+#    define select select_used_without_including_sys_select_h
-+#   else
-      _GL_WARN_ON_USE (select,
-                       "select() used without including <sys/select.h>");
-+#   endif
- #  endif
- # endif
--#endif
- #endif /* _@GUARD_PREFIX@_SYS_TIME_H */
--#endif /* _@GUARD_PREFIX@_SYS_TIME_H */
index 8dc701e044ace3c7dc8838d3cc83f55795c80963..90619287b78bbfbac60638cabf7dce35a009038b 100644 (file)
@@ -9,11 +9,25 @@ GETTEXT_SITE = $(BR2_GNU_MIRROR)/gettext
 GETTEXT_INSTALL_STAGING = YES
 GETTEXT_LICENSE = GPLv2+
 GETTEXT_LICENSE_FILES = COPYING
+GETTEXT_AUTORECONF = YES
+HOST_GETTEXT_AUTORECONF = YES
 
 GETTEXT_DEPENDENCIES = $(if $(BR2_PACKAGE_LIBICONV),libiconv)
 HOST_GETTEXT_DEPENDENCIES = # we don't want the libiconv dependency
 
 GETTEXT_CONF_OPT += \
+       --disable-libasprintf \
+       --disable-acl \
+       --disable-openmp \
+       --disable-rpath \
+       --disable-java \
+       --disable-native-java \
+       --disable-csharp \
+       --disable-relocatable \
+       --without-emacs \
+       --disable-tools
+
+HOST_GETTEXT_CONF_OPT = \
        --disable-libasprintf \
        --disable-acl \
        --disable-openmp \
@@ -42,19 +56,7 @@ define GETTEXT_INSTALL_TARGET_CMDS
        cp -dpf $(STAGING_DIR)/usr/lib/libintl*.so* $(TARGET_DIR)/usr/lib/
 endef
 endif
-# Ditch the tools since they're off and pull other dependencies
-define GETTEXT_DISABLE_TOOLS
-       $(SED) 's/runtime gettext-tools/runtime/' $(@D)/Makefile.in
-endef
 endif # GETTEXT_TOOLS = n
 
-# The tools tests build fails with full toolchain without threads
-define GETTEXT_DISABLE_TESTS
-       $(SED) 's/m4 tests/m4/' $(@D)/gettext-tools/Makefile.in
-endef
-
-GETTEXT_POST_PATCH_HOOKS += GETTEXT_DISABLE_TOOLS
-GETTEXT_POST_PATCH_HOOKS += GETTEXT_DISABLE_TESTS
-
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))