gst1-plugins-bad: enable fdkaac plugin
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 3 Nov 2016 09:58:32 +0000 (06:58 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 6 Nov 2016 22:18:03 +0000 (23:18 +0100)
It's new for 1.10.0, add an explicit option for the fdkaac plugin.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
[Thomas: add missing dependencies for the fdk-aac select, as noticed
by Baruch Siach.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gstreamer1/gst1-plugins-bad/Config.in
package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk

index 2f288cabc6321857b3fde53f9f6b9322f9214435..8af35cc2be918800247ee69f54d15b39c059c1ec 100644 (file)
@@ -520,6 +520,18 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_FBDEV
        help
          Linux framebuffer video sink
 
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_FDK_AAC
+       bool "fdk-aac"
+       select BR2_PACKAGE_FDK_AAC
+       depends on BR2_PACKAGE_FDK_AAC_ARCH_SUPPORTS
+       depends on BR2_INSTALL_LIBSTDCPP
+       help
+         MPEG AAC encoder/decoder
+
+comment "fdk-aac needs a toolchain w/ C++"
+       depends on BR2_PACKAGE_FDK_AAC_ARCH_SUPPORTS
+       depends on !BR2_INSTALL_LIBSTDCPP
+
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_GL
        bool "gl"
        default y
index ac99fcd60084f0da1f1e360446b2abb9a6c06488..cd9da7cbe13815fdd2cb30ce41572206b27ccb44 100644 (file)
@@ -642,6 +642,14 @@ else
 GST1_PLUGINS_BAD_CONF_OPTS += --disable-fbdev
 endif
 
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_FDK_AAC),y)
+GST1_PLUGINS_BAD_CONF_OPTS += --enable-fdk_aac
+GST1_PLUGINS_BAD_DEPENDENCIES += fdk-aac
+GST1_PLUGINS_BAD_HAS_UNKNOWN_LICENSE = y
+else
+GST1_PLUGINS_BAD_CONF_OPTS += --disable-fdk_aac
+endif
+
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_GL),y)
 GST1_PLUGINS_BAD_CONF_OPTS += --enable-gl
 else