package/quota: add optional support for e2fsprogs
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 20 Feb 2016 23:12:05 +0000 (00:12 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Feb 2016 13:39:46 +0000 (14:39 +0100)
When e2fsprogs was compiled before, quota will use it as optional
dependency:

$ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/sbin/quotacheck | grep NEEDED | sort
 0x0000000000000001 (NEEDED)             Shared library: [libcom_err.so.2]
 0x0000000000000001 (NEEDED)             Shared library: [libc.so.1]
 0x0000000000000001 (NEEDED)             Shared library: [libext2fs.so.2]
 0x0000000000000001 (NEEDED)             Shared library: [libintl.so.8]

Quote from configure log before this patch when e2fsprogs were missing:

checking ext2fs/ext2fs.h usability... no
checking ext2fs/ext2fs.h presence... no
checking for ext2fs/ext2fs.h... no
checking for com_err in -lcom_err... no
checking for ext2fs_initialize in -lext2fs... no
configure: WARNING: Ext2 direct support won't be compiled. Libraries not found.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/quota/quota.mk

index a6b03225acae48ddc4099c26a30a6ea550a0af86..c30a2bd85e8dccb882afe9347a8a333436887fbf 100644 (file)
@@ -18,6 +18,13 @@ QUOTA_DEPENDENCIES += gettext
 QUOTA_LIBS += -lintl
 endif
 
+ifeq ($(BR2_PACKAGE_E2FSPROGS),y)
+QUOTA_DEPENDENCIES += e2fsprogs
+QUOTA_CONF_OPTS += --enable-ext2direct
+else
+QUOTA_CONF_OPTS += --disable-ext2direct
+endif
+
 ifeq ($(BR2_PACKAGE_LIBTIRPC),y)
 QUOTA_DEPENDENCIES += libtirpc host-pkgconf
 QUOTA_CFLAGS += `$(PKG_CONFIG_HOST_BINARY) --cflags libtirpc`