package/multimedia/gstreamer
authorDaniel Laird <danieljlaird@hotmail.com>
Wed, 14 Jan 2009 14:38:18 +0000 (14:38 -0000)
committerDaniel Laird <danieljlaird@hotmail.com>
Wed, 14 Jan 2009 14:38:18 +0000 (14:38 -0000)
package/multimedia/gst-plugins-*: I do not want docs installed in rootfs.

Stop it installing the docs in the ROOTFS by using the same fix
as has been applied to cairo.

Signed-off-by: Daniel Laird <daniel.j.laird@nxp.com>
package/multimedia/gst-plugins-base/gst-plugins-base.mk
package/multimedia/gst-plugins-good/gst-plugins-good.mk
package/multimedia/gst-plugins-ugly/gst-plugins-ugly.mk
package/multimedia/gstreamer/gstreamer.mk

index 21f2acaaa98d1cee3ebe9461a9913534713e53e0..2f7f926826bb734e307360cef052034af937baeb 100644 (file)
@@ -17,7 +17,9 @@ GST_PLUGINS_BASE_CONF_OPT = \
                --disable-xshm \
                --disable-oggtest \
                --disable-vorbistest \
-               --disable-freetypetest
+               --disable-freetypetest \
+               --disable-gtk-doc \
+               --without-html-dir
 
 GST_PLUGINS_BASE_DEPENDENCIES = gstreamer liboil
 
index bef8d01b0d6c80a0d81a95deb33f549c65b3ec50..37f6e0abf76fbf7b7a0f3e5e3e33d925769b5fd3 100644 (file)
@@ -22,7 +22,9 @@ GST_PLUGINS_GOOD_CONF_OPT = \
                --disable-aalibtest \
                --disable-esdtest \
                --disable-shout2 \
-               --disable-shout2test
+               --disable-shout2test \
+               --disable-gtk-doc \
+               --without-html-dir
 
 GST_PLUGINS_GOOD_DEPENDENCIES = gstreamer gst-plugins-base
 
index f0cf4789e0aa241b9d27739031d3719fbd432af1..c606ac6d6c01990715ad2754684ae45743ff7f44 100644 (file)
@@ -9,7 +9,9 @@ GST_PLUGINS_UGLY_SITE = http://gstreamer.freedesktop.org/src/gst-plugins-ugly
 
 GST_PLUGINS_UGLY_CONF_OPT = \
                $(DISABLE_NLS) \
-               --disable-examples
+               --disable-examples \
+               --disable-gtk-doc \
+               --without-html-dir
 
 GST_PLUGINS_UGLY_DEPENDENCIES = gstreamer gst-plugins-base
 
index 3d4033e199fc75c30a7f373a46cc6b04bec196fc..194e65f79d2dbd06465bb7d4536a208b147a0448 100644 (file)
@@ -24,6 +24,8 @@ GSTREAMER_CONF_OPT = \
                --disable-examples \
                --disable-tests \
                --disable-failing-tests
+               --disable-gtk-doc \
+               --without-html-dir
 
 GSTREAMER_DEPENDENCIES = libglib2 libxml2 pkgconfig