systemd: add optional dependency on elfutils
authorKeith Mok <ek9852@gmail.com>
Tue, 21 Aug 2018 01:29:20 +0000 (18:29 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 21 Aug 2018 09:19:46 +0000 (11:19 +0200)
systemd can use elfutils when available, so this commit adds the
detection of this library.

Signed-off-by: Keith Mok <ek9852@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/systemd/systemd.mk

index d7031ed21d0e7332f730e785378956ae136a4a8e..48134966707afd8f6d80d14efef9958deec0de82 100644 (file)
@@ -65,6 +65,13 @@ else
 SYSTEMD_CONF_OPTS += -Daudit=false
 endif
 
+ifeq ($(BR2_PACKAGE_ELFUTILS),y)
+SYSTEMD_DEPENDENCIES += elfutils
+SYSTEMD_CONF_OPTS += -Delfutils=true
+else
+SYSTEMD_CONF_OPTS += -Delfutils=false
+endif
+
 # Both options can't be selected at the same time so prefer libidn2
 ifeq ($(BR2_PACKAGE_LIBIDN2),y)
 SYSTEMD_DEPENDENCIES += libidn2