===================================================================
--- kconfig.orig/zconf.tab.c_shipped
+++ kconfig/zconf.tab.c_shipped
-@@ -1515,7 +1515,7 @@
- * later regardless of whether it comes from the 'prompt' in
- * mainmenu_stmt or here
- */
+@@ -1515,7 +1515,7 @@ yyreduce:
+ * later regardless of whether it comes from the 'prompt' in
+ * mainmenu_stmt or here
+ */
- menu_add_prompt(P_MENU, xstrdup("Linux Kernel Configuration"), NULL);
+ menu_add_prompt(P_MENU, xstrdup("Buildroot Configuration"), NULL);
}
--- kconfig.orig/zconf.y
+++ kconfig/zconf.y
@@ -127,7 +127,7 @@ no_mainmenu_stmt: /* empty */
- * later regardless of whether it comes from the 'prompt' in
- * mainmenu_stmt or here
- */
+ * later regardless of whether it comes from the 'prompt' in
+ * mainmenu_stmt or here
+ */
- menu_add_prompt(P_MENU, xstrdup("Linux Kernel Configuration"), NULL);
+ menu_add_prompt(P_MENU, xstrdup("Buildroot Configuration"), NULL);
};
===================================================================
--- kconfig.orig/Makefile
+++ kconfig/Makefile
-@@ -211,7 +211,35 @@ qconf-cxxobjs := qconf.o
+@@ -205,7 +205,35 @@ qconf-cxxobjs := qconf.o
qconf-objs := zconf.tab.o
gconf-objs := gconf.o zconf.tab.o
targets += zconf.lex.c
clean-files := qconf.moc .tmp_qtcheck .tmp_gtkcheck
-@@ -243,7 +243,7 @@ HOSTLOADLIBES_nconf = $(shell \
- || echo "-lmenu -lpanel -lncurses" )
+@@ -243,7 +271,7 @@ HOSTLOADLIBES_nconf = $(shell \
+ || echo "-lmenu -lpanel -lncurses" )
$(obj)/qconf.o: $(obj)/.tmp_qtcheck
-ifeq ($(MAKECMDGOALS),xconfig)
$(obj)/.tmp_qtcheck: $(src)/Makefile
-include $(obj)/.tmp_qtcheck
-@@ -270,9 +276,8 @@
- echo "KC_QT_MOC=$$moc" >> $@
+@@ -270,9 +298,8 @@ $(obj)/.tmp_qtcheck:
+ echo "KC_QT_MOC=$$moc" >> $@
endif
+ifeq ($(MAKECMDGOALS),gconf)
-include $(obj)/.tmp_gtkcheck
# GTK+ needs some extra effort, too...
-@@ -300,11 +305,8 @@
+@@ -300,11 +327,8 @@ $(obj)/zconf.tab.o: $(obj)/zconf.lex.c
$(obj)/qconf.o: $(obj)/qconf.moc
-
+
-quiet_cmd_moc = MOC $@
- cmd_moc = $(KC_QT_MOC) -i $< -o $@
-