kconfig: Refresh patches
authorPetr Vorel <petr.vorel@gmail.com>
Sun, 28 Oct 2018 23:09:52 +0000 (00:09 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 30 Oct 2018 19:58:54 +0000 (20:58 +0100)
Signed-off-by: Petr Vorel <petr.vorel@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
support/kconfig/patches/01-kconfig-kernel-to-buildroot.patch
support/kconfig/patches/06-br-build-system-integration.patch
support/kconfig/patches/14-support-out-of-tree-config.patch

index 92dcf12f9fe8d20fc18a4c145cb8e77967f5900b..43ae61a9c76b745d7b413658d7d8e0a649c8c44f 100644 (file)
@@ -48,10 +48,10 @@ Index: kconfig/zconf.tab.c_shipped
 ===================================================================
 --- kconfig.orig/zconf.tab.c_shipped
 +++ kconfig/zconf.tab.c_shipped
-@@ -1515,7 +1515,7 @@
-        * later regardless of whether it comes from the 'prompt' in
-        * mainmenu_stmt or here
-        */
+@@ -1515,7 +1515,7 @@ yyreduce:
+        * later regardless of whether it comes from the 'prompt' in
+        * mainmenu_stmt or here
+        */
 -      menu_add_prompt(P_MENU, xstrdup("Linux Kernel Configuration"), NULL);
 +      menu_add_prompt(P_MENU, xstrdup("Buildroot Configuration"), NULL);
  }
@@ -62,9 +62,9 @@ Index: kconfig/zconf.y
 --- kconfig.orig/zconf.y
 +++ kconfig/zconf.y
 @@ -127,7 +127,7 @@ no_mainmenu_stmt: /* empty */
-        * later regardless of whether it comes from the 'prompt' in
-        * mainmenu_stmt or here
-        */
+        * later regardless of whether it comes from the 'prompt' in
+        * mainmenu_stmt or here
+        */
 -      menu_add_prompt(P_MENU, xstrdup("Linux Kernel Configuration"), NULL);
 +      menu_add_prompt(P_MENU, xstrdup("Buildroot Configuration"), NULL);
  };
index f03f909bf1f75f735b225b9a8c874df38480c839..35420cbb154ad2740ece2d5ad4ab8da12e9ba779 100644 (file)
@@ -2,7 +2,7 @@ Index: kconfig/Makefile
 ===================================================================
 --- kconfig.orig/Makefile
 +++ kconfig/Makefile
-@@ -211,7 +211,35 @@ qconf-cxxobjs     := qconf.o
+@@ -205,7 +205,35 @@ qconf-cxxobjs     := qconf.o
  qconf-objs    := zconf.tab.o
  gconf-objs    := gconf.o zconf.tab.o
  
@@ -39,8 +39,8 @@ Index: kconfig/Makefile
  
  targets               += zconf.lex.c
  clean-files   := qconf.moc .tmp_qtcheck .tmp_gtkcheck
-@@ -243,7 +243,7 @@ HOSTLOADLIBES_nconf        = $(shell \
-                               || echo "-lmenu -lpanel -lncurses"  )
+@@ -243,7 +271,7 @@ HOSTLOADLIBES_nconf        = $(shell \
+                               || echo "-lmenu -lpanel -lncurses"  )
  $(obj)/qconf.o: $(obj)/.tmp_qtcheck
  
 -ifeq ($(MAKECMDGOALS),xconfig)
@@ -48,8 +48,8 @@ Index: kconfig/Makefile
  $(obj)/.tmp_qtcheck: $(src)/Makefile
  -include $(obj)/.tmp_qtcheck
  
-@@ -270,9 +276,8 @@
-       echo "KC_QT_MOC=$$moc" >> $@
+@@ -270,9 +298,8 @@ $(obj)/.tmp_qtcheck:
+       echo "KC_QT_MOC=$$moc" >> $@
  endif
  
 +ifeq ($(MAKECMDGOALS),gconf)
@@ -59,10 +59,10 @@ Index: kconfig/Makefile
  -include $(obj)/.tmp_gtkcheck
  
  # GTK+ needs some extra effort, too...
-@@ -300,11 +305,8 @@
+@@ -300,11 +327,8 @@ $(obj)/zconf.tab.o: $(obj)/zconf.lex.c
  
  $(obj)/qconf.o: $(obj)/qconf.moc
-
 -quiet_cmd_moc = MOC     $@
 -      cmd_moc = $(KC_QT_MOC) -i $< -o $@
 -
index 5c221b7a13f1cb275e56c5d865c99069571fc56e..a3b33ba688d0ddf0818124a5bf17b3b3cbc5bd84 100644 (file)
@@ -59,7 +59,7 @@ Index: kconfig/confdata.c
        struct stat sb;
 @@ -851,8 +854,20 @@ static int conf_split_config(void)
        conf_read_simple(name, S_DEF_AUTO);
-       sym_calc_value(modules_sym);
+       sym_calc_value(modules_sym);
  
 -      if (chdir("include/config"))
 -              return 1;