sqlcipher: disable tcl support
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 15 Oct 2015 10:42:51 +0000 (07:42 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 15 Oct 2015 11:27:30 +0000 (13:27 +0200)
In commit b1dcb1c2 a fix was attempted at fixing a build failure where
sqlcipher finds the distribution tcl and tries to build against it.
sqlcipher has two tcl usage scenarios: host-tcl which is required to
actually build it, and target tcl to build bindings.
Since cross-compilation of the bindings isn't clean it fails as well,
and since it wasn't a feature before either just disable it completely,
since the wrong fix makes the sqlcipher build failures worse.
Fixes:
http://autobuild.buildroot.net/results/fc0/fc0528de7fed2f34f503fe8dd8b4c21ded0d6dff/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/sqlcipher/sqlcipher.mk

index fadec2207fdf5da39f1a1a2e501f6361208c8a77..196f16275b1b2567a7def7a9e266b348c450d97f 100644 (file)
@@ -15,7 +15,7 @@ SQLCIPHER_CONF_ENV = \
 
 SQLCIPHER_CONF_OPTS = \
        --enable-threadsafe \
-       --with-tcl=$(HOST_DIR)/usr/lib
+       --disable-tcl
 
 SQLCIPHER_CFLAGS += -DSQLITE_HAS_CODEC # Required according to the README
 SQLCIPHER_CONF_ENV += LIBS="-lcrypto -lz"