kmod: workaround for microblaze ld bug
authorWaldemar Brodkorb <wbx@openadk.org>
Sat, 18 Feb 2017 21:40:54 +0000 (22:40 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 19 Feb 2017 21:27:14 +0000 (22:27 +0100)
Add a workaround for a microblaze specific ld bug to avoid
segfault.

Fixes:
  http://autobuild.buildroot.net/results/aef1b915ffd3e5678af8682727c22c5618edfd89

[Peter: force --gc-sections configure check to false instead of patching
  configure]
Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/kmod/kmod.mk

index 7492b926f0c343a2efe7fc8941603ffbdfa66194..407d90d817b795b721e50a4a88d8898ff649c6cf 100644 (file)
@@ -15,6 +15,12 @@ HOST_KMOD_DEPENDENCIES = host-pkgconf
 KMOD_LICENSE = LGPLv2.1+ (library)
 KMOD_LICENSE_FILES = libkmod/COPYING
 
+# --gc-sections triggers binutils ld segfault
+# https://sourceware.org/bugzilla/show_bug.cgi?id=21180
+ifeq ($(BR2_microblaze),y)
+KMOD_CONF_ENV += cc_cv_LDFLAGS__Wl___gc_sections=false
+endif
+
 # static linking not supported, see
 # https://git.kernel.org/cgit/utils/kernel/kmod/kmod.git/commit/?id=b7016153ec8
 KMOD_CONF_OPTS = --disable-static --enable-shared