scrypt: commit packaging improvements
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 28 Aug 2015 12:59:51 +0000 (14:59 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 28 Aug 2015 12:59:51 +0000 (14:59 +0200)
The changes brought by this commit should have been part of the
previous commit, but were not due to a mistake. This commit implements
the following changes to the scrypt package:

   - move from "Libraries -> Crypto" to "System tools", since it only
     installs one binary, scrypt, and no library.
   - bump from 1.1.6 to 1.2.0
   - add comment in the .hash file explaining where the hash is coming
     from.
   - add missing dependency on OpenSSL
   - use BSD-2c as the license code, instead of BSD2
   - use 'main.c' as the license file.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/scrypt/Config.in
package/scrypt/scrypt.hash
package/scrypt/scrypt.mk

index 5b8084d5d5a19bb050f934d59b77ea20169f6ae8..60cda7178a3b3eb953c82dc15e670e4ffa577c7c 100644 (file)
@@ -754,7 +754,6 @@ menu "Crypto"
        source "package/nettle/Config.in"
        source "package/openssl/Config.in"
        source "package/polarssl/Config.in"
-       source "package/scrypt/Config.in"
 endmenu
 
 menu "Database"
@@ -1468,6 +1467,7 @@ endif
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
        source "package/rsyslog/Config.in"
 endif
+       source "package/scrypt/Config.in"
        source "package/smack/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
        source "package/start-stop-daemon/Config.in"
index 8be7f5410f7bde5eda2a11be8cbed929d2c7d2ea..e6d1ac1a651d6a0e2c01e237560f037fdab641ec 100644 (file)
@@ -1,8 +1,9 @@
 config BR2_PACKAGE_SCRYPT
        bool "scrypt"
+       select BR2_PACKAGE_OPENSSL
        help
-         A password-based key derivation function specifically designed
-         to make it costly to perform large-scale custom hardware attacks
-         by requiring large amounts of memory.
+         A password-based key derivation function specifically
+         designed to make it costly to perform large-scale custom
+         hardware attacks by requiring large amounts of memory.
 
          http://www.tarsnap.com/scrypt.html
index e6b690e2405dd1058436b3e8c2dea148f54132c5..66944567635324c29093f2ce352fdb12fa5d756d 100644 (file)
@@ -1 +1,2 @@
-sha256 dfd0d1a544439265bbb9b58043ad3c8ce50a3987b44a61b1d39fd7a3ed5b7fb8  scrypt-1.1.6.tgz
+# From http://www.tarsnap.com/scrypt/scrypt-sigs-1.2.0.asc
+sha256 1754bc89405277c8ac14220377a4c240ddc34b1ce70882aa92cd01bfdc8569d4  scrypt-1.2.0.tgz
index 2db6e2e8910a10299cdf204176379017bf262da1..7ffa7ccf3ff713a90bb7f684a1b1e7e59f671a0a 100644 (file)
@@ -4,10 +4,12 @@
 #
 ################################################################################
 
-SCRYPT_VERSION = 1.1.6
+SCRYPT_VERSION = 1.2.0
 SCRYPT_SOURCE = scrypt-$(SCRYPT_VERSION).tgz
 SCRYPT_SITE = http://www.tarsnap.com/scrypt
-SCRYPT_LICENSE = BSD2
+SCRYPT_LICENSE = BSD-2c
+SCRYPT_LICENSE_FILES = main.c
+SCRYPT_DEPENDENCIES = openssl
 SCRYPT_INSTALL_STAGING = YES
 
 $(eval $(autotools-package))