system: replace nogroup with nobody
authorNorbert Lange <nolange79@gmail.com>
Fri, 17 Jul 2020 21:52:07 +0000 (23:52 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 18 Jul 2020 12:18:33 +0000 (14:18 +0200)
Currently, we define the so-called "overflow group" as 'nogroup'.

However, one practical issue is that systemd-sysusers will otherwise
create a 'nobody' group with gid 999, because that's is what is usual to
define the overflow group: users and groups are defined in LSB (Linux
Standard Base):

    https://refspecs.linuxfoundation.org/LSB_5.0.0/LSB-Core-generic/LSB-Core-generic/usernames.html

Quoting: "If the username exists on a system,then they should be in the
suggested corresponding group".

Only Debian and derivatives depart from this custom, naming it 'nogroup'
(hence the rationale for commit 908198e756b4 (system/skeleton: remove
spurious group 'nobody').

See also commit 9c67af2c52 (system/skeleton: use uid/gid 65534 for
nobody/nogroup), and a related discussion on LWN.net (key is "overflow
UID" which also applies to GID):

    https://lwn.net/Articles/695478/

Use the recommended groupname 'nobody'. Adapt packages accordingly.

Signed-off-by: Norbert Lange <nolange79@gmail.com>
[yann.morin.1998@free.fr:
  - reword commit log
  - extend commit log with more references (commits and LWN)
]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/boa/boa.conf
package/mosquitto/mosquitto.mk
package/oracle-mysql/oracle-mysql.mk
package/systemd/systemd.mk
system/skeleton/etc/group

index e94029665fdb1ce7a1068e4fc701fcc889fe3add..f51c23731619eb4266f1fca1c83e30f54140a562 100644 (file)
@@ -46,7 +46,7 @@ Port 80
 # Group: The group name or GID the server should run as.
 
 User nobody
-Group nogroup
+Group nobody
 
 # ServerAdmin: The email address where server problems should be sent.
 # Note: this is not currently used, except as an environment variable
index 2a9b504eb82bda732290e7249e58fb302616d4af..cdd515e1a4f39d75f697d9823e59f92698d9e943 100644 (file)
@@ -114,7 +114,7 @@ define MOSQUITTO_INSTALL_INIT_SYSTEMD
 endef
 
 define MOSQUITTO_USERS
-       mosquitto -1 nogroup -1 * - - - Mosquitto user
+       mosquitto -1 nobody -1 * - - - Mosquitto user
 endef
 endif
 
index 1449c58e413682d192c16c2dbc23bc3f7178f09c..ccfa40cfb19b9172fe881be31a95fdbce1d9d01e 100644 (file)
@@ -102,7 +102,7 @@ ORACLE_MYSQL_CONF_OPTS += --without-debug
 endif
 
 define ORACLE_MYSQL_USERS
-       mysql -1 nogroup -1 * /var/mysql - - MySQL daemon
+       mysql -1 nobody -1 * /var/mysql - - MySQL daemon
 endef
 
 define ORACLE_MYSQL_ADD_FOLDER
index 0890ac3ac06f13c4f5a6a93f2c3ce5e369b40044..570841ebe3476cd13b7015d558d8b3013474581f 100644 (file)
@@ -38,7 +38,6 @@ SYSTEMD_CONF_OPTS += \
        -Dsulogin-path=/usr/sbin/sulogin \
        -Dmount-path=/usr/bin/mount \
        -Dumount-path=/usr/bin/umount \
-       -Dnobody-group=nogroup \
        -Didn=true \
        -Dnss-systemd=true
 
index 76346b35f2da0d79e5ab4e79459eb1ecff3cd7f0..6822a277bfa619ffbb3a96cb9520e74b0d78f418 100644 (file)
@@ -23,4 +23,4 @@ staff:x:50:
 lock:x:54:
 netdev:x:82:
 users:x:100:
-nogroup:x:65534:
+nobody:x:65534: