libecore: x-includes and x-libraries must be set for cross-compiling
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 3 May 2015 09:44:41 +0000 (11:44 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 3 May 2015 09:44:41 +0000 (11:44 +0200)
If those flags are not explicitly passed, the libecore configure
script will include -I/usr/X11R6/include and -L/usr/X11R6/lib in the
compile flags, which are obviously unsafe for cross-compilation.

The fix is similar to "package/efl/libevas: x-includes and x-libraries
must be set for cross-compiling" done by Romain Naour on libecore.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/efl/libecore/libecore.mk

index dc736871487bfb92a3e8930eb10f8e4d646addea..1f711a8315a316974abe54ebe5fc350019007c29 100644 (file)
@@ -74,7 +74,10 @@ LIBECORE_CONF_OPTS += --disable-ecore-sdl
 endif
 
 ifeq ($(BR2_PACKAGE_LIBECORE_X),y)
-LIBECORE_CONF_OPTS += --enable-ecore-x
+LIBECORE_CONF_OPTS += --enable-ecore-x \
+       --with-x=$(STAGING_DIR) \
+       --x-includes=$(STAGING_DIR)/usr/include \
+       --x-libraries=$(STAGING_DIR)/usr/lib
 LIBECORE_DEPENDENCIES += xlib_libXext xlib_libX11
 else
 LIBECORE_CONF_OPTS += --disable-ecore-x --disable-ecore-imf-xim