package/xz-utils: does not require threads
authorYann E. MORIN <yann.morin.1998@free.fr>
Fri, 9 Jan 2015 17:03:25 +0000 (18:03 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 10 Jan 2015 10:33:15 +0000 (11:33 +0100)
Commit 799c12e (xz-utils: needs threads) tried to fix an autobuild
failure by requiring threads. But xz-utils can be configured without
thread support (even though it is one of the most prominent
selling-points of the latest release!).

[Thomas: use --{enable,disable}-threads instead of
--enable-threads={yes,no}, to match what we generally do in most
autotools packages.]

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/xz/Config.in
package/xz/xz.mk

index 55beb429119457ffe712d002bf04e4cb0cf33bec..50116f29953970994754037f513b247204c9222a 100644 (file)
@@ -1,6 +1,5 @@
 config BR2_PACKAGE_XZ
        bool "xz-utils"
-       depends on BR2_TOOLCHAIN_HAS_THREADS
        help
          XZ is the successor to the Lempel-Ziv/Markov-chain Algorithm
          compression format, which provides memory-hungry but powerful
@@ -13,6 +12,3 @@ config BR2_PACKAGE_XZ
          package.
 
          http://tukaani.org/xz/
-
-comment "xz-utils needs a toolchain w/ threads"
-       depends on !BR2_TOOLCHAIN_HAS_THREADS
index 24b1adb9d924c402e528fb19fa12b5ad42ee9863..413c0205e26fff2215564a3d257a6b8c4a602e65 100644 (file)
@@ -12,5 +12,11 @@ XZ_CONF_ENV = ac_cv_prog_cc_c99='-std=gnu99'
 XZ_LICENSE = GPLv2+ GPLv3+ LGPLv2.1+
 XZ_LICENSE_FILES = COPYING.GPLv2 COPYING.GPLv3 COPYING.LGPLv2.1
 
+ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
+XZ_CONF_OPTS = --enable-threads
+else
+XZ_CONF_OPTS = --disable-threads
+endif
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))