hostcc/hostcxx: fix noccache variant setting
authorMike Frysinger <vapier@gentoo.org>
Mon, 28 Mar 2011 07:18:47 +0000 (03:18 -0400)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 28 Mar 2011 08:29:35 +0000 (10:29 +0200)
The current code accidentally sets up HOSTCC_NOCCACHE and HOSTCXX_NOCCACHE
only when the respective HOSTCC or HOSTCXX values are not set.  So if you
do something like:
make HOSTCC=gcc menuconfig
The build fails because HOSTCC_NOCCACHE is not set anywhere.

Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index 7ae3787bd7e6902b1032adb3df8ae9f0e3739e4a..9aa7399f1daaf2085b89cdce5a57f5b8aeacdc07 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -126,13 +126,13 @@ endif
 ifndef HOSTCC
 HOSTCC:=gcc
 HOSTCC:=$(shell which $(HOSTCC) || type -p $(HOSTCC) || echo gcc)
-HOSTCC_NOCCACHE:=$(HOSTCC)
 endif
+HOSTCC_NOCCACHE:=$(HOSTCC)
 ifndef HOSTCXX
 HOSTCXX:=g++
 HOSTCXX:=$(shell which $(HOSTCXX) || type -p $(HOSTCXX) || echo g++)
-HOSTCXX_NOCCACHE:=$(HOSTCXX)
 endif
+HOSTCXX_NOCCACHE:=$(HOSTCXX)
 ifndef HOSTFC
 HOSTFC:=gfortran
 endif