package/libpjsip: add opencore-amr support
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Tue, 28 Jan 2020 22:22:41 +0000 (23:22 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 29 Jan 2020 16:13:55 +0000 (17:13 +0100)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libpjsip/libpjsip.mk

index 2e6c5abf08afe790e262cb1096b541b2894e0a6f..84919fdc10b1d4f5a2491854be1b93c31c5b25ff 100644 (file)
@@ -28,7 +28,6 @@ LIBPJSIP_CONF_OPTS = \
        --disable-sound \
        --disable-resample \
        --disable-video \
-       --disable-opencore-amr \
        --disable-g7221-codec \
        --disable-ilbc-codec \
        --disable-libwebrtc \
@@ -77,6 +76,13 @@ else
 LIBPJSIP_CONF_OPTS += --disable-libsamplerate
 endif
 
+ifeq ($(BR2_PACKAGE_OPENCORE_AMR),y)
+LIBPJSIP_DEPENDENCIES += opencore-amr
+LIBPJSIP_CONF_OPTS += --with-opencore-amr=$(STAGING_DIR)/usr
+else
+LIBPJSIP_CONF_OPTS += --disable-opencore-amr
+endif
+
 ifeq ($(BR2_PACKAGE_OPUS),y)
 LIBPJSIP_DEPENDENCIES += opus
 LIBPJSIP_CONF_OPTS += --with-opus=$(STAGING_DIR)/usr