package/procps-ng: install libprocps.pc in staging/usr/lib/pkgconfig/
authorRomain Naour <romain.naour@gmail.com>
Sat, 26 Mar 2016 13:27:36 +0000 (14:27 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 26 Mar 2016 17:53:55 +0000 (18:53 +0100)
Since 834893a965a993e8a73e30b448426f626419f3c8, pkg-config --libs libprocps
doesn't work anymore because libprocps.pc is installed in
STAGING_DIR/lib/pkgconfig/ instead of STAGING_DIR/usr/lib/pkgconfig/.

Add --libdir=/usr/lib in PROCPS_NG_CONF_OPTS to fixes the issue.
Note that libprocps.so is now installed in /usr/lib/ instead of /lib/.

Fixes:
http://autobuild.buildroot.net/results/2e5/2e5100ccf1ed336c26b83930e7149941c97fc4d2/

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/procps-ng/procps-ng.mk

index fb1b236feb4f691ee1cbaed402dd556f0f45bce8..51a70a5dc5c02fab739a3e954efbec945f74e5c3 100644 (file)
@@ -35,7 +35,11 @@ endif
 
 # Make sure binaries get installed in /bin, so that they overwrite
 # their busybox counterparts.
-PROCPS_NG_CONF_OPTS += --exec-prefix=/
+# Make sure libprocps.pc is installed in STAGING_DIR/usr/lib/pkgconfig/
+# otherwise it's installed in STAGING_DIR/lib/pkgconfig/ breaking
+# pkg-config --libs libprocps.
+PROCPS_NG_CONF_OPTS += --exec-prefix=/ \
+       --libdir=/usr/lib
 
 # Allows unicode characters to show in 'watch'
 ifeq ($(BR2_PACKAGE_NCURSES_WCHAR),y)