uboot-tools: install libubootenv to staging
authorJörg Krause <joerg.krause@embedded.rocks>
Mon, 2 May 2016 11:16:53 +0000 (13:16 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 6 May 2016 13:58:06 +0000 (15:58 +0200)
libubootenv is required by swupdate.

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
[Thomas: do the installation directly in <pkg>_INSTALL_STAGING_CMDS.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/uboot-tools/uboot-tools.mk

index f47b3db2e063ff1fda747b56fd3b520112d97587..d1ebd6feeed01ff8d4fa3f804e45a684746e9616 100644 (file)
@@ -9,6 +9,7 @@ UBOOT_TOOLS_SOURCE = u-boot-$(UBOOT_TOOLS_VERSION).tar.bz2
 UBOOT_TOOLS_SITE = ftp://ftp.denx.de/pub/u-boot
 UBOOT_TOOLS_LICENSE = GPLv2+
 UBOOT_TOOLS_LICENSE_FILES = Licenses/gpl-2.0.txt
+UBOOT_TOOLS_INSTALL_STAGING = YES
 
 define UBOOT_TOOLS_CONFIGURE_CMDS
        mkdir -p $(@D)/include/config
@@ -58,6 +59,14 @@ define UBOOT_TOOLS_INSTALL_DUMPIMAGE
 endef
 endif
 
+define UBOOT_TOOLS_INSTALL_LIBUBOOTENV
+endef
+
+define UBOOT_TOOLS_INSTALL_STAGING_CMDS
+       $(INSTALL) -D -m 0755 $(@D)/tools/env/lib.a $(STAGING_DIR)/usr/lib/libubootenv.a
+       $(INSTALL) -D -m 0644 $(@D)/tools/env/fw_env.h $(STAGING_DIR)/usr/include/fw_env.h
+endef
+
 define UBOOT_TOOLS_INSTALL_TARGET_CMDS
        $(UBOOT_TOOLS_INSTALL_MKIMAGE)
        $(UBOOT_TOOLS_INSTALL_MKENVIMAGE)