proftpd: install configuration file unconditionally
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 30 Nov 2014 14:18:51 +0000 (15:18 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Dec 2014 23:28:35 +0000 (00:28 +0100)
As discussed, users should use a rootfs overlay or a post-build script
instead of a custom skeleton to override files installed by Buildroot,
so there is no point in having conditions when installing init scripts
or configuration files.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/proftpd/proftpd.mk

index ce66a3f6c18a0524aa0273db31094b08dd835047..0fd8cc86622226edc95071498546cc43ca9d0e33 100644 (file)
@@ -48,10 +48,8 @@ PROFTPD_MAKE = $(MAKE1)
 
 define PROFTPD_INSTALL_TARGET_CMDS
        $(INSTALL) -D -m 0755 $(@D)/proftpd $(TARGET_DIR)/usr/sbin/proftpd
-       @if [ ! -f $(TARGET_DIR)/etc/proftpd.conf ]; then \
-               $(INSTALL) -m 0644 -D $(@D)/sample-configurations/basic.conf $(TARGET_DIR)/etc/proftpd.conf; \
-               $(if $(BR2_INET_IPV6),,$(SED) 's/^UseIPv6/# UseIPv6/' $(TARGET_DIR)/etc/proftpd.conf;) \
-       fi
+       $(INSTALL) -m 0644 -D $(@D)/sample-configurations/basic.conf $(TARGET_DIR)/etc/proftpd.conf; \
+       $(if $(BR2_INET_IPV6),,$(SED) 's/^UseIPv6/# UseIPv6/' $(TARGET_DIR)/etc/proftpd.conf;) \
 endef
 
 define PROFTPD_INSTALL_INIT_SYSV