Fix some stupid bugs in the Xorg build
authorEric Andersen <andersen@codepoet.org>
Wed, 13 Jul 2005 07:36:40 +0000 (07:36 -0000)
committerEric Andersen <andersen@codepoet.org>
Wed, 13 Jul 2005 07:36:40 +0000 (07:36 -0000)
package/xorg/xorg-config.patch
package/xorg/xorg.mk

index 87e836f2765b56eec058f93814fe2a97671060b9..9c92ed12ca1c2898336e1a093e686920e9294ede 100644 (file)
@@ -73,7 +73,7 @@
  #undef PostIncDir
 -#define PostIncDir /skiff/local/lib/gcc-lib/arm-linux/2.95.2/include
 -#define CcCmd /skiff/local/bin/arm-linux-gcc
-+#define PostIncDir REPLACE_STAGING_DIR/lib/gcc-lib/REPLACE_ARCH-linux-uclibc/3.3.3/include
++#define PostIncDir REPLACE_GCCINC_DIR
 +#define CcCmd REPLACE_STAGING_DIR/bin/REPLACE_ARCH-linux-gcc
  #undef CplusplusCmd
 -#define HasCplusplus YES
index 59a6b76dfe7bfd9e9e558f8e8782361895f4c95e..9c2549e5cf05590fd22f7c2ad6d4539d66e28ad0 100644 (file)
@@ -42,11 +42,15 @@ $(DL_DIR)/$(XORG_SOURCE):
 $(XORG_DIR)/.configure: $(DL_DIR)/$(XORG_SOURCE)
        $(XORG_CAT) $(DL_DIR)/$(XORG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
        toolchain/patch-kernel.sh $(XORG_DIR) package/xorg/ xorg\*.patch
+       $(SED) 's:REPLACE_GCCINC_DIR:$(shell $(TARGET_CROSS)gcc -print-file-name=include):g' $(XORG_CF)
        $(SED) 's:REPLACE_STAGING_DIR:$(STAGING_DIR):g' $(XORG_CF)
        $(SED) 's:REPLACE_ARCH:$(ARCH):g' $(XORG_CF)
        $(SED) 's:#define CcCmd.*:#define CcCmd $(TARGET_CROSS)gcc:g' $(XORG_CF)
        $(SED) 's:#define RanlibCmd.*:#define RanlibCmd $(TARGET_CROSS)ranlib:g' $(XORG_CF)
        $(SED) 's:#define LdCmd.*:#define LdCmd $(TARGET_CROSS)ld:g' $(XORG_CF)
+       $(SED) 's:#.*define.*HasPam.*YES::g' $(XORG_DIR)/config/cf/linux.cf
+       $(SED) 's:#.*define.*CrossCompiling.*NO:#define CrossCompiling YES:g' $(XORG_DIR)/config/cf/Imake.tmpl
+       $(SED) 's:#.*undef.*CrossCompileDir.*:#define CrossCompileDir$(STAGING_DIR)/bin:g' $(XORG_DIR)/config/cf/Imake.tmpl
        touch $(XORG_DIR)/.configure
 
 $(XORG_XSERVER): $(XORG_DIR)/.configure