grep: standardise pcre optional dependency
authorBaruch Siach <baruch@tkos.co.il>
Mon, 24 Jul 2017 03:59:53 +0000 (06:59 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 24 Jul 2017 16:23:07 +0000 (18:23 +0200)
Add the 'disable' config option in the 'else' clause of the optional
dependency as is the common pattern.

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/grep/grep.mk

index cfbf2ec7b5372678c685adaae1ea5e670f0f2a2a..06d84ed5b96f9eca36eede527c0294dc0d1a4abf 100644 (file)
@@ -9,8 +9,7 @@ GREP_SITE = $(BR2_GNU_MIRROR)/grep
 GREP_SOURCE = grep-$(GREP_VERSION).tar.xz
 GREP_LICENSE = GPL-3.0+
 GREP_LICENSE_FILES = COPYING
-GREP_CONF_OPTS = --disable-perl-regexp \
-       $(if $(BR2_TOOLCHAIN_USES_MUSL),--with-included-regex)
+GREP_CONF_OPTS = $(if $(BR2_TOOLCHAIN_USES_MUSL),--with-included-regex)
 GREP_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES)
 
 # link with iconv if enabled
@@ -23,6 +22,8 @@ endif
 ifeq ($(BR2_PACKAGE_PCRE),y)
 GREP_CONF_OPTS += --enable-perl-regexp
 GREP_DEPENDENCIES += pcre
+else
+GREP_CONF_OPTS += --disable-perl-regexp
 endif
 
 # Full grep preferred over busybox grep