oprofile: fix install for avr32
authorSimon Dawson <spdawson@gmail.com>
Mon, 16 Dec 2013 08:43:37 +0000 (08:43 +0000)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 16 Dec 2013 11:36:49 +0000 (12:36 +0100)
There is no perf_events support in the kernel for avr32. The oprofile
package makefile hard codes the list of binaries to install. Unfortunately,
this hard-coded list contains pe_profiling/operf, which is only built when
perf_events support is available.

Fixes autobuild failures such as the following.

  http://autobuild.buildroot.net/results/492/492659bc252395a62e62e6005ed0e86e582dcada/

Signed-off-by: Simon Dawson <spdawson@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/oprofile/oprofile.mk

index 186e30cbfa96b0ad6ccf7da578714dcae6c30f6e..07a8ec98c12ed7be1b8f9ee9e5e8928747cb4de4 100644 (file)
@@ -16,7 +16,12 @@ OPROFILE_CONF_OPT = \
 OPROFILE_AUTORECONF = YES
 OPROFILE_BINARIES = utils/ophelp pp/opannotate pp/oparchive pp/opgprof
 OPROFILE_BINARIES += pp/opreport opjitconv/opjitconv daemon/oprofiled
-OPROFILE_BINARIES += utils/op-check-perfevents pe_profiling/operf libabi/opimport
+OPROFILE_BINARIES += utils/op-check-perfevents libabi/opimport
+
+# No perf_events support in kernel for avr32
+ifneq ($(BR2_avr32),y)
+OPROFILE_BINARIES += pe_profiling/operf
+endif
 
 ifeq ($(BR2_i386),y)
 OPROFILE_ARCH = i386