fbv: Allow selection of supported image formats.
authorArn R <arnerro@gmail.com>
Thu, 14 Jun 2012 22:10:18 +0000 (22:10 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 16 Jun 2012 20:34:56 +0000 (22:34 +0200)
This removes fbv's compulsory dependency on either libpng and/or libjpeg and/or libungif.
The user can choose which compressed image format's fbv should support.
By default PNG, JPEG and GIF are selected.
Note that BMP format support will still always be included.

[Peter: Drop (unneeded) png specific libs]
Signed-off-by: Arn R <arnerro@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/fbv/Config.in
package/fbv/fbv.mk

index ea544016805821756fe4c3968ef956f687d726b7..b8a9fe4e44882be88144d2a84cb75e7f5db1fcd5 100644 (file)
@@ -1,11 +1,33 @@
 config BR2_PACKAGE_FBV
        bool "fbv"
-       select BR2_PACKAGE_LIBPNG
-       select BR2_PACKAGE_JPEG
-       select BR2_PACKAGE_LIBUNGIF
        help
          fbv is a very simple graphic file viewer for the framebuffer console,
          capable of displaying GIF, JPEG, PNG and BMP files using libungif,
          libjpeg and libpng.
 
          http://freshmeat.net/projects/fbv/
+
+if BR2_PACKAGE_FBV
+
+config BR2_PACKAGE_FBV_PNG
+       bool "PNG support"
+       default y
+       select BR2_PACKAGE_LIBPNG
+       help
+         Enable support for PNG using libpng.
+
+config BR2_PACKAGE_FBV_JPEG
+       bool "JPEG support"
+       default y
+       select BR2_PACKAGE_JPEG
+       help
+         Enable support for JPEG using IJG's libjpeg.
+
+config BR2_PACKAGE_FBV_GIF
+       bool "GIF support"
+       default y
+       select BR2_PACKAGE_LIBUNGIF
+       help
+         Enable support for GIF using libungif.
+
+endif # BR2_PACKAGE_FBV
index 855a0d42cdaf978699a72450f86807323df98409..7db68022b15314026c50f308e871223ba6452a0a 100644 (file)
@@ -7,7 +7,24 @@ FBV_VERSION:=1.0b
 FBV_SOURCE:=fbv-$(FBV_VERSION).tar.gz
 FBV_SITE:=http://s-tech.elsat.net.pl/fbv
 
-FBV_DEPENDENCIES = libpng jpeg libungif
+### image format dependencies and configure options
+FBV_DEPENDENCIES = # empty
+FBV_CONFIGURE_OPTS = # empty
+ifeq ($(BR2_PACKAGE_FBV_PNG),y)
+FBV_DEPENDENCIES += libpng
+else
+FBV_CONFIGURE_OPTS += --without-libpng
+endif
+ifeq ($(BR2_PACKAGE_FBV_JPEG),y)
+FBV_DEPENDENCIES += jpeg
+else
+FBV_CONFIGURE_OPTS += --without-libjpeg
+endif
+ifeq ($(BR2_PACKAGE_FBV_GIF),y)
+FBV_DEPENDENCIES += libungif
+else
+FBV_CONFIGURE_OPTS += --without-libungif
+endif
 
 #fbv donesn't support cross-compilation
 define FBV_CONFIGURE_CMDS
@@ -16,7 +33,7 @@ define FBV_CONFIGURE_CMDS
                $(TARGET_CONFIGURE_ARGS) \
                ./configure \
                --prefix=/usr \
-               --libs="-lz -lm" \
+               $(FBV_CONFIGURE_OPTS) \
        )
 endef