dropwatch: link with libintl if present
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 31 Jul 2013 19:26:41 +0000 (16:26 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 1 Aug 2013 15:19:05 +0000 (17:19 +0200)
binutils libbfd links to libintl if present, so dropwatch needs it too.
Ugly hardcoded LDFLAGS, but then that's what the dropwatch Makefile
does. Fixes:
http://autobuild.buildroot.net/results/549/54917e7943143e47263b60b4eee3dfc6f0801407/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/dropwatch/dropwatch.mk

index 6c3dc754c813730bc62a469403a991f79f43d3df..09dff6b911583b45415c4b726d300cf6c142db61 100644 (file)
@@ -11,20 +11,28 @@ DROPWATCH_DEPENDENCIES = binutils libnl readline host-pkgconf
 DROPWATCH_LICENSE = GPLv2
 DROPWATCH_LICENSE_FILES = COPYING
 
+# libbfd may be linked to libintl
+# Ugly... but LDFLAGS are hardcoded anyway
+ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE),y)
+DROPWATCH_LDFLAGS = LDFLAGS="-lintl -lbfd -lreadline -lnl-3 -lnl-genl-3"
+endif
+
 define DROPWATCH_BUILD_CMDS
-  $(TARGET_CONFIGURE_OPTS) $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) build
+       $(TARGET_CONFIGURE_OPTS) $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
+               $(DROPWATCH_LDFLAGS) build
 endef
 
 define DROPWATCH_CLEAN_CMDS
-  $(TARGET_CONFIGURE_OPTS) $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) clean
+       $(TARGET_CONFIGURE_OPTS) $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) clean
 endef
 
 define DROPWATCH_INSTALL_TARGET_CMDS
-  $(INSTALL) -D -m 0755 $(@D)/src/dropwatch $(TARGET_DIR)/usr/bin/dropwatch
+       $(INSTALL) -D -m 0755 $(@D)/src/dropwatch \
+               $(TARGET_DIR)/usr/bin/dropwatch
 endef
 
 define DROPWATCH_UNINSTALL_CMDS
-  rm -f $(TARGET_DIR)/usr/bin/dropwatch
+       rm -f $(TARGET_DIR)/usr/bin/dropwatch
 endef
 
 $(eval $(generic-package))