boot/uboot: Set MAKE_ENV for kconfig build system
authorThomas Preston <thomas.preston@codethink.co.uk>
Wed, 5 Sep 2018 12:22:36 +0000 (13:22 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 5 Sep 2018 20:25:04 +0000 (22:25 +0200)
U-Boot fails to build in a GitLab CI context because the kconfig-package
build stage is unable to find bison or flex even though they are
installed in HOST_DIR.

To fix this, set UBOOT_MAKE_ENV so that UBOOT_KCONFIG_MAKE uses the
correct PATH.

Signed-off-by: Thomas Preston <thomas.preston@codethink.co.uk>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
boot/uboot/uboot.mk

index bddafe234d1f5960e19e01994f82b26187a3ba57..a19cb7245859b875abe2cb3b2ba7f93b5648d0f4 100644 (file)
@@ -449,6 +449,7 @@ endif # BR2_TARGET_UBOOT && BR_BUILDING
 ifeq ($(BR2_TARGET_UBOOT_BUILD_SYSTEM_LEGACY),y)
 $(eval $(generic-package))
 else ifeq ($(BR2_TARGET_UBOOT_BUILD_SYSTEM_KCONFIG),y)
+UBOOT_MAKE_ENV = $(TARGET_MAKE_ENV)
 UBOOT_KCONFIG_DEPENDENCIES = \
        $(BR2_BISON_HOST_DEPENDENCY) \
        $(BR2_FLEX_HOST_DEPENDENCY)