rsyslog: enable more basic features
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 13 Jan 2015 23:17:02 +0000 (20:17 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 14 Jan 2015 19:28:34 +0000 (20:28 +0100)
Enable all of the basic modules that don't require any dependencies.
Reasoning is simple, if someone wants rsyslog over a smaller busybox
logger or sysklogd it's probably looking for features.

[Thomas: fix indentation.]

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/rsyslog/rsyslog.mk

index fb5249c0445208b1246d419296e5a0151bc1350f..a45111d085dace8b1f5df0ad9e878f522879f027 100644 (file)
@@ -10,7 +10,12 @@ RSYSLOG_LICENSE = GPLv3 LGPLv3 Apache-2.0
 RSYSLOG_LICENSE_FILES = COPYING COPYING.LESSER COPYING.ASL20
 RSYSLOG_DEPENDENCIES = zlib libestr liblogging json-c host-pkgconf
 RSYSLOG_CONF_ENV = ac_cv_prog_cc_c99='-std=c99'
-RSYSLOG_CONF_OPTS = --disable-generate-man-pages
+RSYSLOG_PLUGINS = imdiag imfile impstats imptcp \
+       mmanon mmaudit mmfields mmjsonparse mmpstrucdata mmsequence mmutf8fix \
+       mail omprog omruleset omstdout omuxsock \
+       pmaixforwardedfrom pmciscoios pmcisconames pmlastmsg pmsnare
+RSYSLOG_CONF_OPTS = --disable-generate-man-pages \
+       $(foreach x,$(call qstrip,$(RSYSLOG_PLUGINS)),--enable-$(x))
 
 # Build after BusyBox
 ifeq ($(BR2_PACKAGE_BUSYBOX),y)