projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
b6d7ce7
)
sudo: fix main executable permissions
author
Simon Dawson
<spdawson@gmail.com>
Sat, 4 Aug 2012 20:11:01 +0000
(21:11 +0100)
committer
Thomas Petazzoni
<thomas.petazzoni@free-electrons.com>
Sat, 4 Aug 2012 21:43:54 +0000
(23:43 +0200)
The sudo executable is installed without the setuid bit set, which prevents
sudo from working.
This patch adds a post-install hook to fix the permissions of the sudo
executable.
Signed-off-by: Simon Dawson <spdawson@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/sudo/sudo.mk
patch
|
blob
|
history
diff --git
a/package/sudo/sudo.mk
b/package/sudo/sudo.mk
index 9b0ebed5717dbb2aef4eaf4a29706e4eda96e127..15e06fa3dcbd0b49366914ece44bb515234de979 100644
(file)
--- a/
package/sudo/sudo.mk
+++ b/
package/sudo/sudo.mk
@@
-14,4
+14,8
@@
SUDO_CONF_OPT = \
--without-interfaces \
--without-pam
+define SUDO_PERMISSIONS
+/usr/bin/sudo f 4755 0 0 - - - - -
+endef
+
$(eval $(autotools-package))