python-serial: new package
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 11 Jan 2011 20:45:55 +0000 (21:45 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 25 Jan 2011 07:59:58 +0000 (08:59 +0100)
python-serial is a Python library to access serial ports.

This package has originally been introduced to test that third-party
pure Python modules (that do not use C extensions) build properly
against the Buildroot Python infrastructure.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/python-serial/Config.in [new file with mode: 0644]
package/python-serial/python-serial.mk [new file with mode: 0644]

index 4f1621b21286d1b90c339f887582036124e092bd..8154907163efd010b8bda75f918772f4e4d89039 100644 (file)
@@ -294,6 +294,7 @@ source "package/libraw1394/Config.in"
 source "package/tslib/Config.in"
 source "package/libusb/Config.in"
 source "package/libusb-compat/Config.in"
+source "package/python-serial/Config.in"
 endmenu
 
 if BROKEN
diff --git a/package/python-serial/Config.in b/package/python-serial/Config.in
new file mode 100644 (file)
index 0000000..ea090bd
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_PYTHON_SERIAL
+       bool "python-serial"
+       depends on BR2_PACKAGE_PYTHON
+       help
+         python-serial is a Python library to access serial ports.
+
+         http://pyserial.sf.net
+
diff --git a/package/python-serial/python-serial.mk b/package/python-serial/python-serial.mk
new file mode 100644 (file)
index 0000000..048930b
--- /dev/null
@@ -0,0 +1,21 @@
+#############################################################
+#
+# python-serial
+#
+#############################################################
+
+PYTHON_SERIAL_VERSION = 2.5
+PYTHON_SERIAL_SOURCE  = pyserial-$(PYTHON_SERIAL_VERSION).tar.gz
+PYTHON_SERIAL_SITE    = http://pypi.python.org/packages/source/p/pyserial/
+
+PYTHON_SERIAL_DEPENDENCIES = python
+
+define PYTHON_SERIAL_BUILD_CMDS
+       (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py build)
+endef
+
+define PYTHON_SERIAL_INSTALL_TARGET_CMDS
+       (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py install --prefix=$(TARGET_DIR)/usr)
+endef
+
+$(eval $(call GENTARGETS,package,python-serial))