package/clamav: fix clamsubmit linking
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 14 Oct 2019 21:05:14 +0000 (23:05 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 14 Oct 2019 21:14:02 +0000 (23:14 +0200)
As suggested by Arnout in review of
https://patchwork.ozlabs.org/patch/1175732/, set OBJC to $(TARGET_CC)

Fixes:
 - http://autobuild.buildroot.org/results/49973b2283c65de5155deaf633cd6569a37af375

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/clamav/clamav.mk

index 18aedd759182c738f6e9fd27436d0ba9c4cf8d17..5caab1e0f6b40cab211d7b2fb25925694f7cdec2 100644 (file)
@@ -22,7 +22,8 @@ CLAMAV_DEPENDENCIES = \
 # mmap cannot be detected when cross-compiling, needed for mempool support
 CLAMAV_CONF_ENV = \
        ac_cv_c_mmap_private=yes \
-       have_cv_ipv6=yes
+       have_cv_ipv6=yes \
+       OBJC=$(TARGET_CC)
 
 ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
 CLAMAV_LIBS += -latomic