Update config.{guess,sub} unconditionally
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 10 Apr 2010 20:18:28 +0000 (22:18 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 11 Apr 2010 03:59:59 +0000 (05:59 +0200)
Remove the BR2_UPDATE_CONFIG option which allowed to globally
enable/disable the replacement of config.{guess,sub} for
autotools-based packages. Doing it unconditionnally just works.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Config.in
package/Makefile.autotools.in
package/gnuconfig/Config.in [deleted file]

index b82a11b3bd4e63fd576a8e4ce4954b768326e788..f2d4a5010ea63a87a991c6f3aa19cd3fda2e9160 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -327,8 +327,6 @@ config BR2_HAVE_DEVFILES
          Install headers and static libraries in the
          target filesystem
 
-source package/gnuconfig/Config.in
-
 endmenu
 
 source "toolchain/Config.in"
index a8dd0511ffa154e43f88916bb1a8d3125da4d865..a4be8c8b32764ae6fb8f18c767bb4a9d1d6c1430 100644 (file)
@@ -128,9 +128,7 @@ define UPDATE_CONFIG_HOOK
        done
 endef
 
-ifeq ($(BR2_UPDATE_CONFIG),y)
 $(2)_POST_PATCH_HOOKS += UPDATE_CONFIG_HOOK
-endif
 
 #
 # Hook to patch libtool to make it work properly for cross-compilation
diff --git a/package/gnuconfig/Config.in b/package/gnuconfig/Config.in
deleted file mode 100644 (file)
index 5ac0bb3..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-config BR2_UPDATE_CONFIG
-       bool "update config.sub and config.guess"
-       default y
-       help
-               This just exists to easily update the config.sub / config.guess
-               files in packages to the latest version (since many bundled ones
-               don't support the latest possible targets)
-