grep: enable optional pcre integration
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 9 Jan 2014 12:12:29 +0000 (09:12 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 9 Jan 2014 12:32:28 +0000 (13:32 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/grep/grep.mk

index 6a039d93537d10025d14b55ed6558a4fae77bb9e..ee6de390e7ec46fbc5f0ee157f38ff90ca2c83cd 100644 (file)
@@ -18,6 +18,12 @@ GREP_CONF_ENV += LIBS=-liconv
 GREP_DEPENDENCIES += libiconv
 endif
 
+# link with pcre if enabled
+ifeq ($(BR2_PACKAGE_PCRE),y)
+GREP_CONF_OPT += --enable-perl-regexp
+GREP_DEPENDENCIES += pcre
+endif
+
 # Full grep preferred over busybox grep
 ifeq ($(BR2_PACKAGE_BUSYBOX),y)
 GREP_DEPENDENCIES += busybox