imx-vpu: Use self-extractible helper
authorJérôme Pouiller <jezz@sysmic.org>
Wed, 19 Nov 2014 21:30:36 +0000 (22:30 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 27 Nov 2014 20:59:58 +0000 (21:59 +0100)
[Thomas: remove unneeded comment about seeing freescale-imx.mk.]

Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/freescale-imx/imx-vpu/imx-vpu.mk

index e0292eda52e9852734513b44df3a90cc402c9b43..ab3634d0f5ec9b0b1abe2d353e8fa79045c91049 100644 (file)
@@ -6,8 +6,6 @@
 
 IMX_VPU_VERSION = $(FREESCALE_IMX_VERSION)
 IMX_VPU_SITE = $(FREESCALE_IMX_SITE)
-IMX_VPU_LICENSE = Freescale License
-IMX_VPU_LICENSE_FILES = EULA vpu/EULA.txt
 IMX_VPU_SOURCE = imx-vpu-$(IMX_VPU_VERSION).bin
 
 IMX_VPU_INSTALL_STAGING = YES
@@ -21,21 +19,12 @@ IMX_VPU_MAKE_ENV = \
        PLATFORM=$(BR2_PACKAGE_FREESCALE_IMX_PLATFORM) \
        INCLUDE="-idirafter $(LINUX_DIR)/include"
 
-# The archive is a shell-self-extractor of a bzipped tar. It happens
-# to extract in the correct directory (imx-vpu-x.y.z)
-# The --force makes sure it doesn't fail if the source dir already exists.
-# The --auto-accept skips the license check - not needed for us
-# because we have legal-info
-# Since there's a EULA in the bin file, extract it to imx-vpu-x.y.z/EULA
-#
+IMX_VPU_LICENSE = Freescale Semiconductor Software License Agreement
+IMX_VPU_LICENSE_FILES = EULA vpu/EULA.txt
+IMX_VPU_REDISTRIBUTE = NO
+
 define IMX_VPU_EXTRACT_CMDS
-       awk 'BEGIN      { start=0; } \
-            /^EOEULA/  { start = 0; } \
-                       { if (start) print; } \
-            /<<EOEULA/ { start=1; }'\
-           $(DL_DIR)/$(IMX_VPU_SOURCE) > $(@D)/EULA
-       cd $(BUILD_DIR); \
-       sh $(DL_DIR)/$(IMX_VPU_SOURCE) --force --auto-accept
+       $(call FREESCALE_IMX_EXTRACT_HELPER,$(DL_DIR)/$(IMX_VPU_SOURCE))
 endef
 
 define IMX_VPU_BUILD_CMDS