p11-kit: new package
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sun, 2 Jun 2013 14:50:52 +0000 (14:50 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 3 Jun 2013 14:49:47 +0000 (16:49 +0200)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/p11-kit/Config.in [new file with mode: 0644]
package/p11-kit/p11-kit.mk [new file with mode: 0644]

index 8a29c99aa572eb56d76536cfcea61b3a03d0f599..0d4ed90e513ead477ed5dd49a0937320508038b8 100644 (file)
@@ -610,6 +610,7 @@ source "package/mpc/Config.in"
 source "package/mpfr/Config.in"
 source "package/mtdev2tuio/Config.in"
 source "package/orc/Config.in"
+source "package/p11-kit/Config.in"
 source "package/poco/Config.in"
 source "package/protobuf/Config.in"
 source "package/protobuf-c/Config.in"
diff --git a/package/p11-kit/Config.in b/package/p11-kit/Config.in
new file mode 100644 (file)
index 0000000..40a07d3
--- /dev/null
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_P11_KIT
+       bool "p11-kit"
+       depends on !BR2_PREFER_STATIC_LIB
+       depends on BR2_USE_MMU
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       select BR2_PACKAGE_LIBTASN1
+       help
+         Provides a way to load and enumerate PKCS#11 modules.
+         Provides a standard configuration setup for installing PKCS#11
+         modules in such a way that they're discoverable.
+
+         http://p11-glue.freedesktop.org/p11-kit.html
+
+comment "p11-kit requires a toolchain with thread support"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/p11-kit/p11-kit.mk b/package/p11-kit/p11-kit.mk
new file mode 100644 (file)
index 0000000..2ddb27c
--- /dev/null
@@ -0,0 +1,15 @@
+#############################################################
+#
+# p11-kit
+#
+#############################################################
+
+P11_KIT_VERSION = 0.18.1
+P11_KIT_SITE = http://p11-glue.freedesktop.org/releases
+P11_KIT_DEPENDENCIES = host-pkgconf libtasn1
+P11_KIT_INSTALL_STAGING = YES
+P11_KIT_CONF_OPT = --disable-static
+P11_KIT_LICENSE = BSD-3c
+P11_KIT_LICENSE_FILES = COPYING
+
+$(eval $(autotools-package))