fftw: Disable combined threads when building with OpenMP support
authorAndré Hentschel <nerv@dawncrow.de>
Wed, 22 Jun 2016 17:00:16 +0000 (19:00 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 2 Jul 2016 13:42:16 +0000 (15:42 +0200)
Otherwise fftw fails to configure:
configure: error: --with-combined-threads incompatible with --enable-openmp

Signed-off-by: André Hentschel <nerv@dawncrow.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/fftw/fftw.mk

index 5045ab6fed15607ddfe3396b229e6d18cddcb517..e89671f9e24b3d3ffb512683685d6b0c8a194c1e 100644 (file)
@@ -31,7 +31,8 @@ FFTW_CFLAGS += $(if $(BR2_PACKAGE_FFTW_USE_NEON),-mfpu=neon)
 
 # Generic optimisations
 ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
-FFTW_CONF_OPTS += --enable-threads --with-combined-threads
+FFTW_CONF_OPTS += --enable-threads
+FFTW_CONF_OPTS += $(if $(BR2_GCC_ENABLE_OPENMP),--without,--with)-combined-threads
 else
 FFTW_CONF_OPTS += --disable-threads
 endif