package/gpsd: remove qt support
authorPeter Korsgaard <peter@korsgaard.com>
Wed, 6 Feb 2019 15:11:15 +0000 (16:11 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Wed, 6 Feb 2019 15:31:06 +0000 (16:31 +0100)
Now that Qt4 is removed, the support in gpsd can be removed as well.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/gpsd/gpsd.mk

index ade2d2a163f8b94310631527b278f15241da85f9..48d21348b946afe6cb31014bb6eb30a2d52d1d57 100644 (file)
@@ -23,7 +23,8 @@ GPSD_SCONS_OPTS = \
        prefix=/usr\
        sysroot=$(STAGING_DIR)\
        strip=no\
-       python=no
+       python=no \
+       qt=no
 
 ifeq ($(BR2_PACKAGE_NCURSES),y)
 GPSD_DEPENDENCIES += ncurses
@@ -48,14 +49,6 @@ ifeq ($(BR2_microblaze),y)
 GPSD_CFLAGS += -O0
 endif
 
-# Enable or disable Qt binding
-ifeq ($(BR2_PACKAGE_QT_NETWORK),y)
-GPSD_SCONS_ENV += QMAKE="$(QT_QMAKE)"
-GPSD_DEPENDENCIES += qt
-else
-GPSD_SCONS_OPTS += qt=no
-endif
-
 # If libusb is available build it before so the package can use it
 ifeq ($(BR2_PACKAGE_LIBUSB),y)
 GPSD_DEPENDENCIES += libusb