package/boost: enable building of boost_log
authorYannick Kiekens <yannickkiekens@gmail.com>
Mon, 20 Oct 2014 13:27:24 +0000 (15:27 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 15 Mar 2015 16:36:40 +0000 (17:36 +0100)
Signed-off-by: Yannick Kiekens <yannickkiekens@gmail.com>
[Thomas: tested on ARM uClibc, and AArch64 glibc, the latter being the
case that used to fail building, and was the reason why boost log had
been disabled.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/boost/Config.in
package/boost/boost.mk

index 574f51ae7e842b4d0b50ad2435d64cb69bd06987..7085c0595cfed2b05e42419b2895c7677d3cbca5 100644 (file)
@@ -88,6 +88,9 @@ config BR2_PACKAGE_BOOST_LOCALE
 comment "boost-locale needs a toolchain w/ wchar"
        depends on !BR2_USE_WCHAR
 
+config BR2_PACKAGE_BOOST_LOG
+        bool "boost-log"
+
 config BR2_PACKAGE_BOOST_MATH
        bool "boost-math"
 
index 70160da4de01c97a909b2ef3480fce62d1a6b0dc..56a6c347ca21a38c0d6198cd209c231760f0fdaa 100644 (file)
@@ -24,8 +24,7 @@ HOST_BOOST_FLAGS = --without-icu \
        serialization signals system test thread timer wave)
 
 # coroutine breaks on some weak toolchains and it's new for 1.54+
-# log breaks with some toolchain combinations and it's new for 1.54+
-BOOST_WITHOUT_FLAGS = coroutine log
+BOOST_WITHOUT_FLAGS = coroutine
 
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_ATOMIC),,atomic)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_CHRONO),,chrono)
@@ -37,6 +36,7 @@ BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_GRAPH),,graph)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_GRAPH_PARALLEL),,graph_parallel)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_IOSTREAMS),,iostreams)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_LOCALE),,locale)
+BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_LOG),,log)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_MATH),,math)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_MPI),,mpi)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_PROGRAM_OPTIONS),,program_options)