webkit: remove user visible rendering target selection
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 25 May 2010 21:25:37 +0000 (23:25 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 25 May 2010 21:25:37 +0000 (23:25 +0200)
Instead use the same logic as in libgtk2. The rendering target selected
MUST be the same as libgtk2's, so just figure it out automatically
instead.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/webkit/Config.in
package/webkit/webkit.mk

index eee6bcb05dbc3064c4e62164dc21732bf4caf5e2..b0d69d787c3d98bb63784c1ec93adc7815d3ff83 100644 (file)
@@ -21,22 +21,3 @@ config BR2_PACKAGE_WEBKIT
 
 comment "webkit requires a toolchain with C++ support and WCHAR enabled"
        depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR
-
-if BR2_PACKAGE_WEBKIT
-
-choice
-       prompt "Rendering target"
-       default BR2_PACKAGE_WEBKIT_X
-       help
-         Selects which rendering target will be used.
-
-config BR2_PACKAGE_WEBKIT_X11
-       bool "X11"
-
-config BR2_PACKAGE_WEBKIT_DIRECTFB
-       bool "DirectFB"
-       select BR2_PACKAGE_DIRECTFB
-
-endchoice
-
-endif
index 2121f4b06d6d019bdcf6da6b5ca9e5321f348311..39debd36230aaca56ffa24eb7f8de0760dece4e1 100644 (file)
@@ -14,12 +14,15 @@ WEBKIT_LIBTOOL_PATCH = NO
 WEBKIT_DEPENDENCIES = host-flex host-gperf icu curl libxml2 libxslt    \
                        libgtk2 sqlite enchant libsoup
 
-ifeq ($(BR2_PACKAGE_WEBKIT_X11),y)
-WEBKIT_CONF_OPT = --with-target=x11
+
+ifeq ($(BR2_PACKAGE_XORG7),y)
+       WEBKIT_CONF_OPT += --with-target=x11
+       WEBKIT_DEPENDENCIES += xserver_xorg-server
 endif
 
-ifeq ($(BR2_PACKAGE_WEBKIT_DIRECTFB),y)
-WEBKIT_CONF_OPT = --with-target=directfb
+ifeq ($(BR2_PACKAGE_DIRECTFB),y)
+       WEBKIT_CONF_OPT += --with-target=directfb
+       WEBKIT_DEPENDENCIES += directfb
 endif
 
 WEBKIT_CONF_OPT += --disable-video