package/belr: new package
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 27 Feb 2020 17:47:13 +0000 (18:47 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 9 Mar 2020 21:13:12 +0000 (22:13 +0100)
Belr is Belledonne Communications' language recognition library, written
in C++11. It parses text inputs formatted according to a language
defined by an ABNF grammar, such as the protocols standardized at IETF.

https://gitlab.linphone.org/BC/public/belr

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/belr/Config.in [new file with mode: 0644]
package/belr/belr.hash [new file with mode: 0644]
package/belr/belr.mk [new file with mode: 0644]

index 4924856bf60987853a67a9fc29b3d12f1340b7d0..6691386863a7420bfb00b595046d0a337a6a5c41 100644 (file)
@@ -828,6 +828,7 @@ F:  package/openzwave/
 N:     Fabrice Fontaine <fontaine.fabrice@gmail.com>
 F:     package/bearssl/
 F:     package/belle-sip/
+F:     package/belr/
 F:     package/boinc/
 F:     package/cairo/
 F:     package/duktape/
index a41143670000c3e5bc8672375240c37557bf62fe..146fc1bbc36339001340d6fb1dbd3c6d1f8e454f 100644 (file)
@@ -1750,6 +1750,7 @@ menu "Other"
        source "package/avro-c/Config.in"
        source "package/bctoolbox/Config.in"
        source "package/bdwgc/Config.in"
+       source "package/belr/Config.in"
        source "package/boost/Config.in"
        source "package/c-capnproto/Config.in"
        source "package/capnproto/Config.in"
diff --git a/package/belr/Config.in b/package/belr/Config.in
new file mode 100644 (file)
index 0000000..f3f742a
--- /dev/null
@@ -0,0 +1,19 @@
+config BR2_PACKAGE_BELR
+       bool "belr"
+       depends on BR2_INSTALL_LIBSTDCPP
+       depends on BR2_TOOLCHAIN_HAS_THREADS # bctoolbox
+       depends on !BR2_TOOLCHAIN_HAS_GCC_BUG_64735 # bctoolbox
+       select BR2_PACKAGE_BCTOOLBOX
+       help
+         Belr is Belledonne Communications' language recognition
+         library, written in C++11. It parses text inputs formatted
+         according to a language defined by an ABNF grammar, such as
+         the protocols standardized at IETF.
+
+         https://gitlab.linphone.org/BC/public/belr
+
+comment "belr needs a toolchain w/ threads, C++"
+       depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS
+
+comment "belr needs a toolchain not affected by GCC bug 64735"
+       depends on BR2_TOOLCHAIN_HAS_GCC_BUG_64735
diff --git a/package/belr/belr.hash b/package/belr/belr.hash
new file mode 100644 (file)
index 0000000..42cf506
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally calculated
+sha256  d6575c36c32828edcaf39df2775070b187019b21fe5fe274e7a85caf54284f05  belr-4.3.1.tar.gz
+sha256  1b3782ccad7b8614100cda30d3faf42fc39f2e97932908c543005053b654ca68  LICENSE.txt
diff --git a/package/belr/belr.mk b/package/belr/belr.mk
new file mode 100644 (file)
index 0000000..8855f94
--- /dev/null
@@ -0,0 +1,26 @@
+################################################################################
+#
+# belr
+#
+################################################################################
+
+BELR_VERSION = 4.3.1
+BELR_SITE = https://gitlab.linphone.org/BC/public/belr/-/archive/$(BELR_VERSION)
+BELR_LICENSE = GPL-3.0+
+BELR_LICENSE_FILES = LICENSE.txt
+BELR_INSTALL_STAGING = YES
+BELR_DEPENDENCIES = bctoolbox
+BELR_CONF_OPTS = \
+       -DENABLE_STRICT=OFF \
+       -DENABLE_TESTS=OFF \
+       -DENABLE_TOOLS=OFF
+
+ifeq ($(BR2_STATIC_LIBS),y)
+BELR_CONF_OPTS += -DENABLE_SHARED=OFF -DENABLE_STATIC=ON
+else ifeq ($(BR2_SHARED_STATIC_LIBS),y)
+BELR_CONF_OPTS += -DENABLE_SHARED=ON -DENABLE_STATIC=ON
+else ifeq ($(BR2_SHARED_LIBS),y)
+BELR_CONF_OPTS += -DENABLE_SHARED=ON -DENABLE_STATIC=OFF
+endif
+
+$(eval $(cmake-package))