package/python-asgiref: new package
authorAdam Duskett <Aduskett@gmail.com>
Sun, 4 Aug 2019 01:16:28 +0000 (21:16 -0400)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 27 Sep 2019 21:53:36 +0000 (23:53 +0200)
ASGI is a standard for Python asynchronous web apps and servers to
communicate with each other, and positioned as an asynchronous
successor to WSGI.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/python-asgiref/Config.in [new file with mode: 0644]
package/python-asgiref/python-asgiref.hash [new file with mode: 0644]
package/python-asgiref/python-asgiref.mk [new file with mode: 0644]

index e572d40d6812c3c101febb3b6d0ac2fe9c254d90..c5132df788eedbf6dcb024ca69cfdfdec901cdd9 100644 (file)
@@ -54,6 +54,7 @@ F:    package/openjdk-bin/
 F:     package/php/
 F:     package/policycoreutils/
 F:     package/python3/
+F!     package/python-asgiref/
 F:     package/python-django-enumfields/
 F:     package/python-flask-sqlalchemy/
 F:     package/python-mutagen/
index 69864df434208bfb9b5a751a606b6c86f13bf24f..9b4aa7dac9ae68353311dde3366eff6fe83f19a1 100644 (file)
@@ -829,6 +829,7 @@ menu "External python modules"
        source "package/python-alsaaudio/Config.in"
        source "package/python-argh/Config.in"
        source "package/python-arrow/Config.in"
+       source "package/python-asgiref/Config.in"
        source "package/python-asn1crypto/Config.in"
        source "package/python-async-timeout/Config.in"
        source "package/python-attrs/Config.in"
diff --git a/package/python-asgiref/Config.in b/package/python-asgiref/Config.in
new file mode 100644 (file)
index 0000000..d0b816c
--- /dev/null
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_PYTHON_ASGIREF
+       bool "python-asgiref"
+       help
+         ASGI is a standard for Python asynchronous web apps and
+         servers to communicate with each other, and positioned as
+         an asynchronous successor to WSGI.
+
+         This package includes ASGI base libraries, such as:
+           - Sync-to-async and async-to-sync function wrappers,
+             asgiref.sync
+           - Server base classes, asgiref.server
+           - A WSGI-to-ASGI adapter, in asgiref.wsgi
+
+         http://github.com/django/asgiref/
diff --git a/package/python-asgiref/python-asgiref.hash b/package/python-asgiref/python-asgiref.hash
new file mode 100644 (file)
index 0000000..61ec9eb
--- /dev/null
@@ -0,0 +1,5 @@
+# md5, sha256 from https://pypi.org/pypi/asgiref/json
+md5    682697d39175a9681222dd6f304d8e51  asgiref-3.2.0.tar.gz
+sha256 cefcbd64acbfc9f38913566824ef070dd9a50e63f1b4cc5a7f1c44be809d7ff3  asgiref-3.2.0.tar.gz
+# Locally computed sha256 checksums
+sha256 b846415d1b514e9c1dff14a22deb906d794bc546ca6129f950a18cd091e2a669  LICENSE
diff --git a/package/python-asgiref/python-asgiref.mk b/package/python-asgiref/python-asgiref.mk
new file mode 100644 (file)
index 0000000..0ffc16d
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-asgiref
+#
+################################################################################
+
+PYTHON_ASGIREF_VERSION = 3.2.0
+PYTHON_ASGIREF_SOURCE = asgiref-$(PYTHON_ASGIREF_VERSION).tar.gz
+PYTHON_ASGIREF_SITE = https://files.pythonhosted.org/packages/65/ef/e357b3e3d418f16d8f79b9d0c44d170bc0d88f0840b5755b6bfe25a576ea
+PYTHON_ASGIREF_SETUP_TYPE = setuptools
+PYTHON_ASGIREF_LICENSE = BSD-3-Clause
+PYTHON_ASGIREF_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))