package/rsyslog: fix wrong symlink for systemd service
authorPetr Kulhavy <brain@jikos.cz>
Wed, 20 Sep 2017 10:10:34 +0000 (12:10 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 24 Sep 2017 13:50:29 +0000 (15:50 +0200)
The symlink to /etc/systemd/system/syslog.service was pointing 4 levels up
to /usr/lib instead of 3 levels up.

This wasn't an issue on the actual system (/../ equals to / ) but was causing a
deadlink in the TARGET directory.

Signed-off-by: Petr Kulhavy <brain@jikos.cz>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/rsyslog/rsyslog.mk

index bbf7d951087f42efe239326ed343297e2b17b8da..e32505be22ff9ece1c3c4118fb1db862d22e6db9 100644 (file)
@@ -91,7 +91,7 @@ define RSYSLOG_INSTALL_INIT_SYSTEMD
        mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
        ln -sf ../../../../usr/lib/systemd/system/rsyslog.service \
                $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/rsyslog.service
-       ln -sf ../../../../usr/lib/systemd/system/rsyslog.service \
+       ln -sf ../../../usr/lib/systemd/system/rsyslog.service \
                $(TARGET_DIR)/etc/systemd/system/syslog.service
 endef