Oops... forgot --with-headers when building the cross compilers. So the
authorManuel Novoa III <mjn3@codepoet.org>
Wed, 14 Jan 2004 19:05:27 +0000 (19:05 -0000)
committerManuel Novoa III <mjn3@codepoet.org>
Wed, 14 Jan 2004 19:05:27 +0000 (19:05 -0000)
version of limits.h under gcc-lib was incorrect.

make/gcc-uclibc-2.95.mk
make/gcc-uclibc-3.3.mk

index 1feb98bf3601a9fa0214fbc4da5b5c0f890b1b56..c9f1b92da33ef6ffa89d93abf2fd52aa2cc68383 100644 (file)
@@ -75,6 +75,8 @@ $(GCC_DIR)/.patched: $(GCC_DIR)/.unpacked
 # # the step or libgcc will not build...
 $(GCC_BUILD_DIR1)/.configured: $(GCC_DIR)/.patched
        mkdir -p $(GCC_BUILD_DIR1)
+       -mkdir -p $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/include
+       -(cd $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME) ; ln -sf include sys-include)
        (cd $(GCC_BUILD_DIR1); PATH=$(TARGET_PATH) \
                $(GCC_DIR)/configure \
                --prefix=$(STAGING_DIR) \
@@ -84,6 +86,7 @@ $(GCC_BUILD_DIR1)/.configured: $(GCC_DIR)/.patched
                --enable-languages=c \
                --disable-shared \
                --includedir=$(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/include \
+               --with-headers \
                --disable-__cxa_atexit \
                --enable-target-optspace \
                --with-gnu-ld \
@@ -164,6 +167,7 @@ $(GCC_BUILD_DIR2)/.configured: $(GCC_DIR)/.patched $(STAGING_DIR)/$(REAL_GNU_TAR
                --enable-languages=$(TARGET_LANGUAGES) \
                --enable-shared \
                --with-gxx-include-dir=$(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/include/c++ \
+               --with-headers \
                --disable-__cxa_atexit \
                --enable-target-optspace \
                --with-gnu-ld \
index 1946a6376b88d6b9eb5225087ed813298520d49d..8d2d20db2b26e3b709eeef28fe61a37a999f595b 100644 (file)
@@ -75,6 +75,8 @@ endif
 # # the step or libgcc will not build...
 $(GCC_BUILD_DIR1)/.configured: $(GCC_DIR)/.patched
        mkdir -p $(GCC_BUILD_DIR1)
+       -mkdir -p $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/include
+       -(cd $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME) ; ln -sf include sys-include)
        (cd $(GCC_BUILD_DIR1); PATH=$(TARGET_PATH) \
                $(GCC_DIR)/configure \
                --prefix=$(STAGING_DIR) \
@@ -84,6 +86,7 @@ $(GCC_BUILD_DIR1)/.configured: $(GCC_DIR)/.patched
                --enable-languages=c \
                --disable-shared \
                --includedir=$(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/include \
+               --with-headers \
                --disable-__cxa_atexit \
                --enable-target-optspace \
                --with-gnu-ld \
@@ -129,6 +132,7 @@ $(GCC_BUILD_DIR2)/.configured: $(GCC_DIR)/.patched $(STAGING_DIR)/$(REAL_GNU_TAR
                --enable-languages=$(TARGET_LANGUAGES) \
                --enable-shared \
                --with-gxx-include-dir=$(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/include/c++ \
+               --with-headers \
                --disable-__cxa_atexit \
                --enable-target-optspace \
                --with-gnu-ld \