Update to Python 2.4.5 (latest patch rev of 2.4)
authorHamish Moffatt <hamish@cloud.net.au>
Tue, 2 Sep 2008 00:54:49 +0000 (00:54 -0000)
committerHamish Moffatt <hamish@cloud.net.au>
Tue, 2 Sep 2008 00:54:49 +0000 (00:54 -0000)
Remove the test suite before building, else it will fail to compile depending on what modules have been configured.

package/python/python.mk

index 53d59c812f3f574ee6a0d8741b2b9b45ad2d1b69..919c932acf276118322eaeadfc5b1f2493803d29 100644 (file)
@@ -3,7 +3,7 @@
 # python
 #
 #############################################################
-PYTHON_VERSION=2.4.2
+PYTHON_VERSION=2.4.5
 PYTHON_VERSION_SHORT=2.4
 PYTHON_SOURCE:=Python-$(PYTHON_VERSION).tar.bz2
 PYTHON_SITE:=http://python.org/ftp/python/$(PYTHON_VERSION)
@@ -124,6 +124,7 @@ $(TARGET_DIR)/$(PYTHON_TARGET_BINARY): $(PYTHON_DIR)/$(PYTHON_BINARY)
 ifneq ($(BR2_PACKAGE_PYTHON_SSL),y)
        export PYTHON_DISABLE_SSL=1
 endif
+       rm -rf $(PYTHON_DIR)/Lib/test
        LD_LIBRARY_PATH=$(STAGING_DIR)/lib
        $(MAKE) CC=$(TARGET_CC) -C $(PYTHON_DIR) install \
                DESTDIR=$(TARGET_DIR) CROSS_COMPILE=yes \