linux: fix copy of Busybox config to target directory
authorHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Fri, 3 Oct 2008 07:24:34 +0000 (07:24 -0000)
committerHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Fri, 3 Oct 2008 07:24:34 +0000 (07:24 -0000)
This patch fixes bug report #5204. The Busybox config was not copied from the
correct place.

Signed-off-by: Hans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
target/linux/Makefile.in.advanced

index 402830c7af4850e865366b66cd8418602c5fbb8d..cfdba952507801d359508d14a86abea5170ce6d3 100644 (file)
@@ -428,7 +428,7 @@ $(TARGET_DIR)/boot/uclibc.config: $(UCLIBC_DIR)/.config
 
 $(TARGET_DIR)/boot/busybox.config: $(BUSYBOX_DIR)/.config
        mkdir -p $(TARGET_DIR)/boot
-       cp -dpf .config $(TARGET_DIR)/boot/busybox.config
+       cp -dpf $(BUSYBOX_DIR)/.config $(TARGET_DIR)/boot/busybox.config
 
 /tftpboot/$(LINUX26_KERNEL_NAME): $(LINUX26_KERNEL)
        -mkdir -p /tftpboot