mutt: Add options for imap/pop3 support, enable optional iconv/OpenSSL support
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 13 Apr 2014 12:14:17 +0000 (14:14 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 14 Apr 2014 21:35:47 +0000 (23:35 +0200)
[Thomas: keep a normal 'config' instead of 'menuconfig' for mutt.]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mutt/Config.in
package/mutt/mutt.mk

index 430eeb8f1ebb00fba19d2c62c3da58927b857967..d85c1a7f7da0aab6ec49864e628fba004eb42928 100644 (file)
@@ -8,6 +8,20 @@ config BR2_PACKAGE_MUTT
 
          http://www.mutt.org/
 
+if BR2_PACKAGE_MUTT
+
+config BR2_PACKAGE_MUTT_IMAP
+       bool "imap"
+       help
+         IMAP support
+
+config BR2_PACKAGE_MUTT_POP3
+       bool "pop3"
+       help
+         POP3 support
+
+endif # BR2_PACKAGE_MUTT
+
 comment "mutt needs a toolchain w/ wchar"
        depends on BR2_USE_MMU
        depends on !BR2_USE_WCHAR
index 5aa18ebcb0e91467f6bcdc012abb6755acf7396b..633b2afc72445389c82cd7ae1f8d52f42b633f91 100644 (file)
@@ -9,7 +9,36 @@ MUTT_SITE = http://downloads.sourceforge.net/project/mutt/mutt
 MUTT_LICENSE = GPLv2+
 MUTT_LICENSE_FILES = GPL
 MUTT_DEPENDENCIES = ncurses
-MUTT_CONF_OPT = --disable-iconv --disable-smtp
+MUTT_CONF_OPT = --disable-smtp
 MUTT_AUTORECONF = YES
 
+ifeq ($(BR2_PACKAGE_LIBICONV),y)
+MUTT_DEPENDENCIES += libiconv
+MUTT_CONF_OPT += --enable-iconv
+endif
+
+ifeq ($(BR2_PACKAGE_MUTT_IMAP),y)
+MUTT_CONF_OPT += --enable-imap
+else
+MUTT_CONF_OPT += --disable-imap
+endif
+
+ifeq ($(BR2_PACKAGE_MUTT_POP3),y)
+MUTT_CONF_OPT += --enable-pop
+else
+MUTT_CONF_OPT += --disable-pop
+endif
+
+# SSL support is only used by imap or pop3 module
+ifneq ($(BR2_PACKAGET_MUTT_IMAP)$(BR2_PACKAGE_MUTT_POP3),)
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+MUTT_DEPENDENCIES += openssl
+MUTT_CONF_OPT += --with-ssl=$(STAGING_DIR)/usr
+else
+MUTT_CONF_OPT += --without-ssl
+endif
+else
+MUTT_CONF_OPT += --without-ssl
+endif
+
 $(eval $(autotools-package))