wireshark: remove documentation
authorGilles Chanteperdrix <gilles.chanteperdrix@xenomai.org>
Tue, 14 Jun 2016 15:11:15 +0000 (17:11 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 14 Jun 2016 20:33:37 +0000 (22:33 +0200)
Remove html and txt documentation from the rootfs as they unlikely to be
needed.

[Peter: use xargs instead of GNU extensions as suggested by Yann]
Signed-off-by: Gilles Chanteperdrix <gilles.chanteperdrix@xenomai.org>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/wireshark/wireshark.mk

index 59670f93967505579bd6d4f341d646e023bcc0d2..55f931b3bd566f9498b89934f3593fff2a083b1c 100644 (file)
@@ -99,4 +99,11 @@ else
 WIRESHARK_CONF_OPTS += --with-sbc=no
 endif
 
+define WIRESHARK_REMOVE_DOCS
+       find $(TARGET_DIR)/usr/share/wireshark -name '*.txt' -print0 \
+               -o -name '*.html' -print0 | xargs -0 rm -f
+endef
+
+WIRESHARK_POST_INSTALL_TARGET_HOOKS += WIRESHARK_REMOVE_DOCS
+
 $(eval $(autotools-package))