ffmpeg: enable use of freetype and fontconfig
authorSteve Kenton <skenton@ou.edu>
Tue, 27 Jan 2015 01:22:35 +0000 (19:22 -0600)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 27 Jan 2015 22:06:18 +0000 (23:06 +0100)
Configure ffmpeg to use freetype and fontconfig
if those packages are selected.

ffmpeg freetype support require fenv.h, which is not available in uClibc or
musl, except for certain archs / depending on specific configuration
options, so only enable it for glibc.

[Peter: only enable on glibc, simplify logic]
Signed-off-by Stephen M. Kenton <skenton@ou.edu>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ffmpeg/ffmpeg.mk

index bc8c2209836b9635ccee5b8031ca7c5aadefb09c..16f53be6998e2bdc802b4afbf7da5de39fc99ebb 100644 (file)
@@ -49,7 +49,6 @@ FFMPEG_CONF_OPTS = \
        --disable-libopencv \
        --disable-libdc1394 \
        --disable-libfaac \
-       --disable-libfreetype \
        --disable-libgsm \
        --disable-libmp3lame \
        --disable-libnut \
@@ -234,6 +233,22 @@ else
 FFMPEG_CONF_OPTS += --disable-libvpx
 endif
 
+# ffmpeg freetype support require fenv.h which is only
+# available/working on glibc
+ifeq ($(BR2_PACKAGE_FREETYPE)$(BR2_TOOLCHAIN_USES_GLIBC),yy)
+FFMPEG_CONF_OPTS += --enable-libfreetype
+FFMPEG_DEPENDENCIES += freetype
+else
+FFMPEG_CONF_OPTS += --disable-libfreetype
+endif
+
+ifeq ($(BR2_PACKAGE_FONTCONFIG),y)
+FFMPEG_CONF_OPTS += --enable-fontconfig
+FFMPEG_DEPENDENCIES += fontconfig
+else
+FFMPEG_CONF_OPTS += --disable-fontconfig
+endif
+
 ifeq ($(BR2_PACKAGE_X264)$(BR2_PACKAGE_FFMPEG_GPL),yy)
 FFMPEG_CONF_OPTS += --enable-libx264
 FFMPEG_DEPENDENCIES += x264