linux: error out early if user forgot to specify dts name(s)
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 15 Apr 2013 06:55:53 +0000 (08:55 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 15 Apr 2013 06:55:53 +0000 (08:55 +0200)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
linux/linux.mk

index 2fff2e9ce7af2f1753c8059fb705c908ce0bbd4f..d375cf0328027d5890ee22f4b84854e0f60782e0 100644 (file)
@@ -58,6 +58,11 @@ else ifeq ($(BR2_LINUX_KERNEL_USE_CUSTOM_DTS),y)
 KERNEL_DTS_NAME = $(basename $(notdir $(BR2_LINUX_KERNEL_CUSTOM_DTS_PATH)))
 endif
 
+ifeq ($(BR2_LINUX_KERNEL_DTS_SUPPORT)$(KERNEL_DTS_NAME),y)
+$(error No kernel device tree source specified, check your \
+BR2_LINUX_KERNEL_USE_INTREE_DTS / BR2_LINUX_KERNEL_USE_CUSTOM_DTS settings)
+endif
+
 ifeq ($(BR2_LINUX_KERNEL_APPENDED_DTB),y)
 ifneq ($(words $(KERNEL_DTS_NAME)),1)
 $(error Kernel with appended device tree needs exactly one DTS source.\