Install xorg modules correctly
authorEric Andersen <andersen@codepoet.org>
Fri, 15 Jul 2005 07:07:44 +0000 (07:07 -0000)
committerEric Andersen <andersen@codepoet.org>
Fri, 15 Jul 2005 07:07:44 +0000 (07:07 -0000)
package/xorg/xorg.mk

index b41cc1882d65db41858c063171b635fa67ac4c93..1c3f5fe00aa4fb64661090f97a20c580e7db2011 100644 (file)
@@ -75,7 +75,7 @@ $(TARGET_XSERVER): $(XORG_XSERVER)
        cp -f $(XORG_DIR)/programs/xinit/xinit $(XORG_BINX)
        chmod a+x $(XORG_BINX)/startx $(XORG_BINX)/xauth $(XORG_BINX)/xinit
        mkdir -p $(XORG_LIBX)/modules
-       cp -dRf $(XORG_DIR)/exports/lib/modules/ $(XORG_LIBX)/modules/
+       cp -LRf $(XORG_DIR)/exports/lib/modules/ $(XORG_LIBX)/
        ( cd $(XORG_DIR)/fonts ; $(MAKE) DESTDIR=$(TARGET_DIR) install XCURSORGEN=xcursorgen MKFONTSCALE=mkfontscale )
        #( cd $(XORG_DIR) ; $(MAKE) DESTDIR=$(TARGET_DIR) install XCURSORGEN=xcursorgen MKFONTSCALE=mkfontscale )
        (cd $(TARGET_DIR)/usr/bin; ln -snf $(TARGET_BINX) X11)