linux: adjust kernel config according to the Buildroot configuration
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 8 Jun 2010 11:56:19 +0000 (13:56 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 22 Jun 2010 19:20:27 +0000 (21:20 +0200)
We only adjust the configuration or ARM EABI and IPv6. The (more
complicated) initramfs case is handled in a separate commit. The user
is expected to take care of all other configuration details (like
having Netfilter enabled to make iptables work, etc.)

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
linux/linux.mk

index 8b83e306611d5070ffe4c99504ceff0af3426aa3..71d9616034fb0fd1091c005f383b8108f15d2d20 100644 (file)
@@ -84,6 +84,16 @@ ifeq ($(BR2_LINUX_KERNEL_USE_DEFCONFIG),y)
        $(TARGET_MAKE_ENV) $(MAKE1) $(LINUX26_MAKE_FLAGS) -C $(@D) $(call qstrip,$(BR2_LINUX_KERNEL_DEFCONFIG))_defconfig
 else ifeq ($(BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG),y)
        cp $(BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE) $(@D)/.config
+endif
+ifeq ($(BR2_ARM_EABI),y)
+       $(call KCONFIG_ENABLE_OPT,CONFIG_AEABI,$(@D)/.config)
+else
+       $(call KCONFIG_DISABLE_OPT,CONFIG_AEABI,$(@D)/.config)
+endif
+ifeq ($(BR2_INET_IPV6),y)
+       $(call KCONFIG_ENABLE_OPT,CONFIG_IPV6,$(@D)/.config)
+else
+       $(call KCONFIG_DISABLE_OPT,CONFIG_IPV6,$(@D)/.config)
 endif
        $(TARGET_MAKE_ENV) $(MAKE) $(LINUX26_MAKE_FLAGS) -C $(@D) oldconfig
        $(Q)touch $@